您的位置:首页 > 其它

uva 400 - Unix ls

2012-06-12 13:40 281 查看
Unix ls
The computer company you work for is introducing a brand new computer line and is developing a new Unix-like operating system to be introduced along with the new computer. Your assignment is to write the formatter for the
ls function.

Your program will eventually read input from a pipe (although for now your program will read from the input file). Input to your program will consist of a list of (F) filenames that you will sort (ascending based on the ASCII character values) and
format into (C) columns based on the length (L) of the longest filename. Filenames will be between 1 and 60 (inclusive) characters in length and will be formatted into left-justified columns. The rightmost column will be the width of the
longest filename and all other columns will be the width of the longest filename plus 2. There will be as many columns as will fit in 60 characters. Your program should use as few rows (R) as possible with rows being filled to capacity from left to
right.

Input

The input file will contain an indefinite number of lists of filenames. Each list will begin with a line containing a single integer (


). There will then be
N lines each containing one left-justified filename and the entire line's contents (between 1 and 60 characters) are considered to be part of the filename. Allowable characters are alphanumeric (a to
z, A to Z, and 0 to 9) and from the following set
{ ._- }
(not including the curly braces). There will be no illegal characters in any of the filenames and no line will be completely empty.

Immediately following the last filename will be the N for the next set or the end of file. You should read and format all sets in the input file.

Output

For each set of filenames you should print a line of exactly 60 dashes (-) followed by the formatted columns of filenames. The sorted filenames 1 to
R will be listed down column 1; filenames R+1 to 2R listed down column 2; etc.

Sample Input

10
tiny
2short4me
very_long_file_name
shorter
size-1
size2
size3
much_longer_name
12345678.123
mid_size_name
12
Weaser
Alfalfa
Stimey
Buckwheat
Porky
Joe
Darla
Cotton
Butch
Froggy
Mrs_Crabapple
P.D.
19
Mr._French
Jody
Buffy
Sissy
Keith
Danny
Lori
Chris
Shirley
Marsha
Jan
Cindy
Carol
Mike
Greg
Peter
Bobby
Alice
Ruben


Sample Output

------------------------------------------------------------
12345678.123         size-1
2short4me            size2
mid_size_name        size3
much_longer_name     tiny
shorter              very_long_file_name
------------------------------------------------------------
Alfalfa        Cotton         Joe            Porky
Buckwheat      Darla          Mrs_Crabapple  Stimey
Butch          Froggy         P.D.           Weaser
------------------------------------------------------------
Alice       Chris       Jan         Marsha      Ruben
Bobby       Cindy       Jody        Mike        Shirley
Buffy       Danny       Keith       Mr._French  Sissy
Carol       Greg        Lori        Peter


题意:读入n个字符串,按字典序排序,再按列优先输出,附加条件每行最多输出60个字符,在此条件下要求行最少。

计算行数line=60/(Lenmax+2);超过60 line=0;应该为1,runtime error 1次;

然后陷入无限runtime error,受题目条件迷惑每行最多输出60个字符,所以定义数组就61,貌似后台有超过60的,开大点就过了,runtime error 无语╮(╯▽╰)╭

#include <stdio.h>

#include <string.h>

char s[10000][500];

void main()

{char temp[500];

int n,i,j,k,len,lmax,line,column,num,sum;

while (scanf("%d",&n)!=EOF)

{getchar();

lmax=0;

for (i=1;i<=n;i++)

{scanf("%s",&s[i]);

len=strlen(s[i]);

if (len>lmax) lmax=len;

}

for (i=1;i<n;i++)

for (j=i+1;j<=n;j++)

if (strcmp(s[i],s[j])>0) {strcpy(temp,s[i]);strcpy(s[i],s[j]);strcpy(s[j],temp);}

printf("------------------------------------------------------------\n");

line=60/(lmax+2);

if (line==0) line=1;

column=n/line;

if (n%line!=0) ++column;

sum=0;

for (j=0;j<column;j++)

{for (i=1;i<=line;i++)

{num=column*i-column+1+j;

if (num<=n)

{++sum;

printf("%s",s[num]);

len=strlen(s[num]);

if (sum<n)

for (k=len;k<lmax+2;k++)

printf(" ");

}

}

printf("\n");

}

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: