您的位置:首页 > 其它

HDU-1081 To The Max -----求子矩阵最大和

2012-06-04 12:43 387 查看

To The Max

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 5023 Accepted Submission(s):
2384


[align=left]Problem Description[/align]

Given a two-dimensional array of positive and negative
integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater
located within the whole array. The sum of a rectangle is the sum of all the
elements in that rectangle. In this problem the sub-rectangle with the largest
sum is referred to as the maximal sub-rectangle.

As an example, the
maximal sub-rectangle of the array:

0 -2 -7 0
9 2 -6 2
-4 1 -4
1
-1 8 0 -2

is in the lower left corner:

9 2
-4 1
-1
8

and has a sum of 15.

[align=left]Input[/align]

The input consists of an N x N array of integers. The
input begins with a single positive integer N on a line by itself, indicating
the size of the square two-dimensional array. This is followed by N 2 integers
separated by whitespace (spaces and newlines). These are the N 2 integers of the
array, presented in row-major order. That is, all numbers in the first row, left
to right, then all numbers in the second row, left to right, etc. N may be as
large as 100. The numbers in the array will be in the range
[-127,127].

[align=left]Output[/align]

Output the sum of the maximal sub-rectangle.

[align=left]Sample Input[/align]

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2

[align=left]Sample Output[/align]

15

#include<stdio.h>
#include<string.h>
int a[101][101],max[101];
int main()
{
int maxsum,r,c,m,n,i,j;
while(scanf("%d",&n)!=EOF)
{
for(i=1;i<=n;++i)
for(j=1;j<=n;++j)
{
scanf("%d",&a[i][j]);
a[i][j]+=a[i-1][j];
}
maxsum=a[1][1];
for(i=0;i<n;++i)//注意这里技巧,从零开始;
{
for(j=i+1;j<=n;++j)
{
memset(max,0,sizeof(max));
for(m=1;m<=n;++m)
{
if(max[m-1]>=0)
max[m]=max[m-1]+a[j][m]-a[i][m];//a[j][m]-a[i][m]即为第m列中第i+1行到第j行之和
else
max[m]=a[j][m]-a[i][m];
if(maxsum<max[m])
maxsum=max[m];
}
}
}
printf("%d\n",maxsum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: