您的位置:首页 > 其它

uva 414 - Machined Surfaces

2012-06-01 16:46 309 查看
An imaging device furnishes digital images of two machined surfaces that eventually will be assembled in contact with each other. The roughness of this final contact is to be estimated.

A digital image is composed of the two characters, "X" and " " (space). There are always 25 columns to an image, but the number of rows,
N, is variable. Column one (1) will always have an "X" in it and will be part of the left surface. The left surface can extend to the right from column one (1) as contiguous
X's.

Similarly, column 25 will always have an "X" in it and will be part of the right surface. The right surface can extend to the left from column 25 as contiguous
X's.

Digital-Image View of Surfaces

Left     		                           Right

[code]XXXX                                              XXXXX



XXX                                             XXXXXXX


XXXXX                                              XXXX


XX                                               XXXXXX


.                                                     .


.                                                     .


.                                                     .


XXXX                                               XXXX


XXX                                              XXXXXX







1 25

[/code]

In each row of the image, there can be zero or more space characters separating the left surface from the right surface. There will never be more than a single blank
region in any row.

For each image given, you are to determine the total ``void" that will exist after the left surface has been brought into contact with the right surface. The ``void" is the total count of the spaces that remains between the left and right surfaces after
theyhave been brought into contact.

The two surfaces are brought into contact by displacing them strictly horizontally towards each other until a rightmost
"X" of the left surface of some row is immediately to the left of the leftmost
"X" of the right surface of that row. There is no rotation or twisting of these two surfaces as they are brought into contact; they remain rigid, and only move horizontally.

Note: The original image may show the two surfaces already in contact, in which case no displacement enters into the contact roughness estimation.

Input

The input consists of a series of digital images. Each image data set has the following format:

First line - A single unsigned integer, N, with value greater than zero (0) and less than 13. The first digit of
N will be the first character on a line.

Next N lines - Each line has exactly 25 characters; one or more X's, then zero or more spaces, then one or more
X's.

The end of data is signaled by a null data set having a zero on the first line of an image data set and no further data.

Output

For each image you receive as a data set, you are to reply with the total void (count of spaces remaining after the surfaces are brought into contact). Use the default output for a single integer on a line.

Sample Input
(character "B" for ease of reading. The actual input file will use the ASCII-space character, not
"B").

4
XXXXBBBBBBBBBBBBBBBBXXXXX
XXXBBBBBBBBBBBBBBBXXXXXXX
XXXXXBBBBBBBBBBBBBBBBXXXX
XXBBBBBBBBBBBBBBBBBXXXXXX
2
XXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXX
1
XXXXXXXXXBBBBBBBBBBBBBBXX
0


Sample Output

4
0
0


题目很难懂,看了别人的大意是,B代表空格然后右边的向左边压缩知道某一行没有B,统计剩下的空格数,

没有空格就是B最少的一行,所以找住最小的一行空格数,统计所有空格数,然后减去每行的压缩了的空格

#include <stdio.h>

#include <string.h>

void main()

{char s[26];

int sum,n,i,j,min,l,num;

while (scanf("%d",&n),n)

{getchar();

min=26; sum=0;

for (i=1;i<=n;i++)

{gets(s);

num=0;

l=strlen(s);

for (j=0;j<l;j++)

if (s[j]=='X') ++num;

num=25-num;

if (min>num) min=num;

sum+=num;

}

printf("%d\n",sum-n*min);

}

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: