您的位置:首页 > Web前端 > HTML

【UVA】【第0章】414 - Machined Surfaces

2012-05-27 17:29 447 查看


 Machined Surfaces 
An imaging device furnishes digital images of two machined surfaces thateventually will be assembled incontact with each other. The roughness of this final contact is to be estimated.

A digital image is composed of the two characters, "X" and " "(space). There are always 25 columns to animage, but the number of rows,N, is variable. Column one (1) will alwayshave an"X" in it and will bepart of the left
surface. The left surface can extend to the right fromcolumn one (1) as contiguousX's.

Similarly, column 25 will always have an "X" in it and will be partof the right surface. The right surfacecan extend to the left from column 25 as contiguousX's.

Digital-Image View of Surfaces

Left     		                           Right


XXXX                                              XXXXX



XXX                                             XXXXXXX


XXXXX                                              XXXX


XX                                               XXXXXX


.                                                     .


.                                                     .


.                                                     .


XXXX                                               XXXX


XXX                                              XXXXXX







1 25

In each row of the image, there can be zero or more space charactersseparating the left surface from the right surface.There will never be more than a single blankregion in any row.

For each image given, you are to determine the total ``void" that willexist after the left surface has beenbrought into contact with the right surface. The ``void" is the totalcount of the spaces that remains betweenthe left and right surfaces after theyhave
been brought into contact.

The two surfaces are brought into contact by displacing them strictlyhorizontally towards each other until arightmost"X" of the left surface of some row is immediately to theleft of the leftmost"X" of the right surface of that row.There
is no rotation or twisting of these two surfaces as they are broughtinto contact; they remain rigid, and only move horizontally.

Note: The original image may show the two surfaces already in contact,in which case no displacement enters into the contact roughness estimation.

Input

The input consists of a series of digital images. Each image data set hasthe following format:

First line -A single unsigned integer, N, with value greater thanzero (0) and less than 13. Thefirst digit ofN will be the first character on a line.

Next N lines -Each line has exactly 25 characters; one or more X's, then zero or more spaces, then one or moreX's.

The end of data is signaled by a null data set having a zero on the firstline of an image data set and no further data.

Output

For each image you receive as a data set, you are to reply with the totalvoid (count of spaces remainingafter the surfaces are brought into contact). Use the default output fora single integer on a line.

Sample Input(character"B" for ease of reading.The actual input file will use the ASCII-space character, not"B").

4
XXXXBBBBBBBBBBBBBBBBXXXXX
XXXBBBBBBBBBBBBBBBXXXXXXX
XXXXXBBBBBBBBBBBBBBBBXXXX
XXBBBBBBBBBBBBBBBBBXXXXXX
2
XXXXXXXXXXXXXXXXXXXXXXXXX
XXXXXXXXXXXXXXXXXXXXXXXXX
1
XXXXXXXXXBBBBBBBBBBBBBBXX
0


Sample Output

4
0
0

这道题尼玛生单词真多

都不认识 我去啊

LRJ 就弄些 读不懂的题 本来我找度娘翻译 翻译结果如下

表面加工

一个成像设备提供数字图像的加工表面,最终将聚集在相互接触。这样的粗糙度估计是最后的接触。

数字图像是由2个字,“”和“”(空间)。总是有25个列的图像,但一些行,氮,是可变的。列一(1)将始终有一个“×”,将一部分的左侧面。左表面可以延伸到从第一列(1)连续的十的。

同样,25列将始终有一个“×”,将一部分的表面。正确的表面可以延伸到左栏25连续的十的。

数字图像的表面

左右

公司xxxxx tex2html_wrap_inline50

×××xxxxxxx

xxxxx某某

二十xxxxxx

。。

。。

。。

* * * *

×××xxxxxx tex2html_wrap_inline52

tex2html_wrap_inline54tex2html_wrap_inline56

125

在每一行的图像,可以有零个或多个字符的空间分离的左表面从表面。永远不会有多于一个单一的空白区域中的任何行。

对于每一个图像,你确定总` `无效”,将存在左后表面被带进接触表面的权利。该`
`无效”是总计数的空间之间的左侧和右侧表面后,他们被带进接触。

两者的表面被带进接触取代严格的横向相互接近到最右边的“×”的左表面的一些行立即向左边的最左边的“×”的正面,行。有不旋转或扭曲这些表面作为他们被带进接触;他们保持刚性,只有水平移动。

注:原始图像可能显示的表面已经接触,在这种情况下没有位移进入接触粗糙度估计。

输入

输入由一系列数字图像。每一个图像数据集有以下格式:

第一行—

一个无符号整数,氮,与大于零的值(0)和小于13。第一个数字,将是第一个在一行。

下北线—

每行25字;一个或多个,然后零个或多个空格,那么一个或多个的。

数据结束标志为无效数据集有一零在第一行的图像数据集并没有进一步的资料。

输出功率

对于每一个图像你收到的数据集,你回复总无效(计数空间后剩余的表面被带进接触)。使用默认输出一个整数,在线上。

样本输入(“乙”,为便于阅读。实际文件将使用ascii-space而言,没有“乙”)。

4

公司bbbbbbbbbbbbbbbb xxxxx

×××bbbbbbbbbbbbbbb xxxxxxx

xxxxx bbbbbbbbbbbbbbbb某某

二十bbbbbbbbbbbbbbbbb xxxxxx

2

xxxxxxxxxxxxxxxxxxxxxxxxx

xxxxxxxxxxxxxxxxxxxxxxxxx

1

xxxxxxxxx bbbbbbbbbbbbbb某某

0

样例输出

4

0

0

我就滚回去读英文题了……

这尼玛什么度娘啊

我凭强大的猜题能力读懂了这个题什么意思

就是把左右相接 留下的空格算出来

也就是找x最多的一行

再扫描一遍 ans += (delta)就A了

记得用getline

不然会挂 因为中间不是B 是‘ ’

代码如下:

#include <cstdlib>
#include <cstdio>
#include <cstring>
#include <iomanip>
#include <string>
#include <iostream>
#define max(a, b) (a > b ? a : b)
using namespace std;

int N;
string s[15];
int ans = 0;
int Max = -1;

void init_file()
{
freopen("White_GS_6.in", "r", stdin);
freopen("White_GS_6.out", "w", stdout);
}

void read_data()
{
while(scanf("%d \n", &N) == 1 &&  N != 0)
{
ans = 0;
//	  printf("N = %d\n", N);
Max = -1;
for(int i = 0; i < N; i++)
{
getline(cin, s[i]);
int x = s[i].size();
int K = 0;
for(int j = 0; j < x; j++)
{
if (s[i][j] == 'X') K++;
}
Max = max(Max, K);
}
//	printf("Max = %d\n", Max);
for(int i = 0; i < N; i++)
{
int K = 0;
int x = s[i].size();
for(int j = 0; j < x; j++)
{
if (s[i][j] == 'X') K++;
}
ans += (Max - K);
}
printf("%d\n", ans);
}
}

void work()
{

}

int main()
{
init_file();
read_data();
work();
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息