您的位置:首页 > 其它

POJ2070浅析------Filling Out the Team

2012-05-25 19:34 316 查看
Filling Out the Team

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 8634Accepted: 4756
Description
Over the years, the people of the great city of Pittsburgh have repeatedly demonstrated a collective expertise at football second to none. Recently a spy has discovered the true source of the city's football power-a wizard known
only as "Myron," who is infallible at selecting the proper position at which each player will excel.

Now that you know the source of Pittsburgh's wisdom, you are determined to provide your school's football team with a computer program that matches the wisdom of "Myron." You have consulted with the best football minds you can find, and they have dispensed
their wisdom on the slowest speed, minimum weight, and minimum strength required to play each position.



Using this knowledge, you will develop a program that reads in several players physical attributes and outputs what position(s) they are able to play.
Input
Each line of the input file will list the attributes for one player:

< speed > < weight > < strength >

Each number will be a real-valued number. The file will end with a line reading "0 0 0"
Output
For each player, you will output one line listing the positions that player can play. A player can play a position if each of their attributes is greater or equal to the minimum for weight and strength, and less than or equal to
the slowest speed. If a player can play multiple positions, output them in the order listed above, separated by whitespace. You may leave an extra space at the end of the line. If a player can play no positions, write "No positions" on the line.
Sample Input
4.4 180 200
5.5 350 700
4.4 205 350
5.2 210 500
0 0 0

Sample Output
Wide Receiver
Lineman
Wide Receiver Quarterback
No positions

Source
Mid-Atlantic 2004

题目大意:输入数据,输出对应数组。

题目类型:简单计算

备注:水题!!!直接上代码。

我的代码如下:
#include<stdio.h>
int main()
{
double s,w,l;
int i,flag;
char ss[100]="";
while(scanf("%lf%lf%lf",&s,&w,&l)&&s&&w&&l)
{
flag=0;
if(s<=4.5&&w>=150&&l>=200)
{
printf("Wide Receiver ");
flag=1;
}
if(s<=6.0&&w>=300&&l>=500)
{
printf("Lineman ");
flag=1;
}
if(s<=5.0&&w>=200&&l>=300)
{
printf("Quarterback ");
flag=1;
}
if(!flag)
printf("No positions\n");
else printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: