您的位置:首页 > 其它

1001:Sum Problem

2012-05-24 19:30 281 查看
Problem Description
Hey, welcome to HDOJ(Hangzhou Dianzi University Online Judge).

In this problem, your task is to calculate SUM(n) = 1 + 2 + 3 + ... + n.
Input
The input will consist of a series of integers n, one integer per line.
Output
For each case, output SUM(n) in one line, followed by a blank line. You may assume the result will be in the range of 32-bit signed integer.

Sample Input
1
100


Sample Output
1

5050


answer:

import java.util.Scanner;

public class Main{

public static void main(String[] args) {

Scanner scan = new Scanner(System.in);
long i,sum,n;
while(scan.hasNextLong())
{

n = scan.nextLong();
sum = 0;
for(i=1; i<=n;i++)
{
sum = sum+i;
}
System.out.println(sum);
System.out.print("\r\n");
}
}


注意点:最后一行的空格要写成:\r\n,windows中的空格就是这样!
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: