您的位置:首页 > 编程语言 > Java开发

HDU 1089----1096 A+B for Input-Output Practice(简单题)(JAVA版)

2012-05-20 15:54 411 查看
1089 A+B for Input-Output Practice (I)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 43745 Accepted Submission(s): 24698



Problem Description

Your task is to
Calculate a + b.

Too easy?! Of course! I specially designed the problem for acm beginners.

You must have found that some problems have the same titles with this one, yes,
all these problems were designed for the same aim.

Input

The input will
consist of a series of pairs of integers a and b, separated by a space, one
pair of integers per line.

Output

For each pair of
input integers a and b you should output the sum of a and b in one line, and
with one line of output for each line in input.

Sample Input

1 5

10 20

Sample Output

6

30

Author

lcy

import java.util.Scanner;
public class Main
{
public static void main(String[] args)
{
Scanner scan = new Scanner (System.in);
int a, b;
while (scan.hasNextInt())
{
a = scan.nextInt();
b = scan.nextInt();
System.out.println(a + b);
}
}
}


1090 A+B for Input-Output Practice (II)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 33209 Accepted Submission(s): 22107


Problem Description

Your task is to
Calculate a + b.

Input

Input contains an
integer N in the first line, and then N lines follow. Each line consists of a
pair of integers a and b, separated by a space, one pair of integers per line.

Output

For each pair of
input integers a and b you should output the sum of a and b in one line, and
with one line of output for each line in input.

Sample Input

2

1 5

10 20

Sample Output

6

30

import java.util.Scanner;
public class Main
{
public static void main(String[] args)
{
Scanner scan = new Scanner (System.in);
int a, b, n;
n = scan.nextInt();
do
{
a = scan.nextInt();
b = scan.nextInt();
System.out.println(a + b);
}while (--n > 0);
}
}


1091 A+B for Input-Output Practice (III)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 39905 Accepted Submission(s): 20319


Problem Description

Your task is to
Calculate a + b.

Input

Input contains
multiple test cases. Each test case contains a pair of integers a and b, one
pair of integers per line. A test case containing 0 0 terminates the input and
this test case is not to be processed.

Output

For each pair of
input integers a and b you should output the sum of a and b in one line, and
with one line of output for each line in input.

Sample Input

1 5

10 20

0 0

Sample Output

6

30

import java.util.Scanner;
public class Main
{
public static void main(String[] args)
{
Scanner scan = new Scanner (System.in);
int a, b;
while(scan.hasNextInt())
{
a = scan.nextInt();
b = scan.nextInt();
if (a == 0 && b == 0)
{
break;
}
System.out.println(a + b);
}

}
}


1092 A+B for Input-Output Practice (IV)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 35513 Accepted Submission(s): 18958


Problem Description

Your task is to
Calculate the sum of some integers.

Input

Input contains
multiple test cases. Each test case contains a integer N, and then N integers
follow in the same line. A test case starting with 0 terminates the input and
this test case is not to be processed.

Output

For each group of
input integers you should output their sum in one line, and with one line of
output for each line in input.

Sample Input

4 1 2 3 4

5 1 2 3 4 5

0

Sample Output

10

15

import java.util.Scanner;
public class Main
{
public static void main(String[] args)
{
Scanner scan = new Scanner (System.in);
int a, ans, n, i;
while (scan.hasNextInt())
{
n = scan.nextInt();
if (n == 0)
{
break;
}
ans = 0;
for (i = 0; i < n; ++i)
{
a = scan.nextInt();
ans += a;
}
System.out.println(ans);
}
}
}


1093 A+B for Input-Output Practice (V)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 25874 Accepted Submission(s): 17521



Problem Description

Your task is to
calculate the sum of some integers.

Input

Input contains an
integer N in the first line, and then N lines follow. Each line starts with a
integer M, and then M integers follow in the same line.

Output

For each group of
input integers you should output their sum in one line, and with one line of
output for each line in input.

Sample Input

2

4 1 2 3 4

5 1 2 3 4 5

Sample Output

10

15

import java.util.Scanner;
public class Main
{
public static void main(String[] args)
{
Scanner scan = new Scanner(System.in);
int ans, a, n, m,  i, j;
m = scan.nextInt();
for (j = 0; j < m; ++j)
{
n = scan.nextInt();
ans = 0;
for (i = 0; i < n; ++i)
{
a = scan.nextInt();
ans += a;
}
System.out.println(ans);
}
}
}


1094 A+B for Input-Output Practice (VI)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24178 Accepted Submission(s): 1636


Problem Description

Your task is to
calculate the sum of some integers.

Input

Input contains
multiple test cases, and one case one line. Each case starts with an integer N,
and then N integers follow in the same line.

Output

For each test case
you should output the sum of N integers in one line, and with one line of
output for each line in input.

Sample Input

4 1 2 3 4

5 1 2 3 4 5

Sample Output

10

15

import java.util.Scanner;
public class Main{
public static void main(String[] args){
Scanner scan = new Scanner(System.in);
int ans, a, n, i;
while (scan.hasNext()){
n = scan.nextInt();
ans = 0;
for (i = 0; i < n; ++i){
a = scan.nextInt();
ans += a;
}
System.out.println(ans);
}
}
}


1095 A+B for Input-Output Practice (VII)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 24499 Accepted Submission(s): 16097


Problem Description

Your task is to
Calculate a + b.

Input

The input will
consist of a series of pairs of integers a and b, separated by a space, one
pair of integers per line.

Output

For each pair of
input integers a and b you should output the sum of a and b, and followed by a
blank line.

Sample Input

1 5

10 20

Sample Output

6

30

import java.util.Scanner;
public class Main{
public static void main (String[] args) {
Scanner scan = new Scanner(System.in);
int a, b;
while (scan.hasNext()){
a = scan.nextInt();
b = scan.nextInt();
System.out.println(a + b);
System.out.println();
}
}
}


1096 A+B for Input-Output Practice (VIII)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 52764 Accepted Submission(s): 15997


Problem Description

Your task is to
calculate the sum of some integers.

Input

Input contains an
integer N in the first line, and then N lines follow. Each line starts with a
integer M, and then M integers follow in the same line.

Output

For each group of
input integers you should output their sum in one line, and you must note that
there is a blank line between outputs.

Sample Input

3

4 1 2 3 4

5 1 2 3 4 5

3 1 2 3

Sample Output

10

15

6

这道题最后不用输出空行

import java.util.Scanner;
public class Main{
public static void main (String[] args) {
Scanner scan = new Scanner(System.in);
int a, n, ans, i, m, j;
n = scan.nextInt();
for (i = 1; i <= n; ++i){
ans = 0;
m = scan.nextInt();
for (j = 0; j < m; ++j){
a = scan.nextInt();
ans += a;
}
System.out.println(ans);
if (i < n){
System.out.println();
}
}
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: