您的位置:首页 > 其它

UVa 494 - Kindergarten Counting Game

2012-05-20 11:16 447 查看
Everybody sit down in a circle. Ok. Listen to me carefully.

``Woooooo, you scwewy wabbit!''

Now, could someone tell me how many words I just said?

Input and Output

Input to your program will consist of a series of lines, each line containing multiple words (at least one). A ``word'' is defined as a consecutive sequence of letters (upper and/or lower case).

Your program should output a word count for each line of input. Each word count should be printed on a separate line.

Sample Input

Meep Meep!
I tot I taw a putty tat.
I did! I did! I did taw a putty tat.
Shsssssssssh ... I am hunting wabbits. Heh Heh Heh Heh ...


Sample Output

2
7
10
9

题义:判断单词的个数。水题。

代码如下:


#include<stdio.h>
#include<string.h>

int main()
{
int n, i, num, word;
char str[1000];
while(gets(str))
{
num=0;
word=1;
n=strlen(str);
for (i=0; i<n; i++)
{
if ((str[i] >= 'a' && str[i] <= 'z') || (str[i]>='A' && str[i] <= 'Z'))
{
if (word)
{
num++;
}
word=0;
}
else
{
word=1;
}
}
printf("%d\n", num);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: