您的位置:首页 > 其它

UVa 10300 - Ecological Premium

2012-05-20 09:49 232 查看
German farmers are given a premium depending on the conditions at their farmyard. Imagine the following simplified regulation: you know the size of each farmer's farmyard in square meters and the number of animals living at it. We won't make a difference between different animals, although this is far from reality. Moreover you have information about the degree the farmer uses environment-friendly equipment and practices, expressed in a single integer greater than zero. The amount of money a farmer receives can be calculated from these parameters as follows. First you need the space a single animal occupies at an average. This value (in square meters) is then multiplied by the parameter that stands for the farmer's environment-friendliness, resulting in the premium a farmer is paid per animal he owns. To compute the final premium of a farmer just multiply this premium per animal with the number of animals the farmer owns.

Input

The first line of input contains a single positive integer n (<20), the number of test cases. Each test case starts with a line containing a single integer f (0<f<20), the number of farmers in the test case. This line is followed by one line per farmer containing three positive integers each: the size of the farmyard in square meters, the number of animals he owns and the integer value that expresses the farmer’s environment-friendliness. Input is terminated by end of file. No integer in the input is greater than 100000 or less than 0.

Output

For each test case output one line containing a single integer that holds the summed burden for Germany's budget, which will always be a whole number. Do not output any blank lines.

Sample Input

3

5

1 1 1

2 2 2

3 3 3

2 3 4

8 9 2

3

9 1 8

6 12 1

8 1 1

3

10 30 40

9 8 5

100 1000 70

Sample Output

38

86

7445

题意:第一行输入一个测试用例的数量,第二行输入农夫测试用例的数量,接着是m行数据的输入,每行3个数据,第一个数据是农夫 拥有的土地面积,第二个数据是农夫拥有的动物的数量,第三个是生态系数。计算公式是 土地面积/动物数量 × 生态系数 ×动物数量

AC代码如下:

#include<stdio.h>

int main()
{
int n, m, a, b, c, sum;
scanf("%d", &n);
while (n--)
{
scanf("%d", &m);
sum=0;
while(m--)
{
scanf("%d%d%d", &a, &b, &c);
sum+=a*c;
}
printf("%d\n", sum);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: