您的位置:首页 > 其它

hdu 1081 To The Max

2012-05-18 21:45 337 查看

To The Max

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 4437 Accepted Submission(s): 2099



[align=left]Problem Description[/align]
Given a two-dimensional array of positive and negative integers, a sub-rectangle is any contiguous sub-array of size 1 x 1 or greater located within the whole array. The sum of a rectangle is the sum of all the elements in that rectangle.
In this problem the sub-rectangle with the largest sum is referred to as the maximal sub-rectangle.

As an example, the maximal sub-rectangle of the array:

0 -2 -7 0

9 2 -6 2

-4 1 -4 1

-1 8 0 -2

is in the lower left corner:

9 2

-4 1

-1 8

and has a sum of 15.

[align=left]Input[/align]
The input consists of an N x N array of integers. The input begins with a single positive integer N on a line by itself, indicating the size of the square two-dimensional array. This is followed by N 2 integers separated by whitespace
(spaces and newlines). These are the N 2 integers of the array, presented in row-major order. That is, all numbers in the first row, left to right, then all numbers in the second row, left to right, etc. N may be as large as 100. The numbers in the array will
be in the range [-127,127].

[align=left]Output[/align]
Output the sum of the maximal sub-rectangle.

[align=left]Sample Input[/align]

4
0 -2 -7 0 9 2 -6 2
-4 1 -4 1 -1
8 0 -2


[align=left]Sample Output[/align]

15


[align=left]Source[/align]
Greater New York 2001

可以根据最大子段,引申出来

#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 50008
using namespace std;
int prim
,numprim
;
bool isnoprime
;
int next;
void primm()
{
memset(isnoprime,0,sizeof(isnoprime));
next=0;
int i,j,k;
for(i=2;i<N;i++)
{
if(!isnoprime[i])
{prim[++next]=i;}
for(j=i+i;j<N;j++)
{
isnoprime[j]=1;
}
}
}
void DP()
{
memset(numprim,999999,sizeof(numprim));
numprim[0]=0;
numprim[1]=0;
int k;
for(int i=0;i<N;i++)
{
for(int j=1;j<=next&&(i+prim[j])<=N;j++)
{
numprim[i+prim[j]]=min(numprim[i+prim[j]],numprim[i]+1);

}
for(int j=1;j<=next&&i*prim[j]<=N;j++)
numprim[i*prim[j]]=min(numprim[i*prim[j]],numprim[i]+1);
}
}
int main()
{
int m;
scanf("%d",&m);
primm();
DP();
int a,b;
while(m--)
{
scanf("%d%d",&a,&b);
int sum=0;
for(int i=a;i<=b;i++)
sum+=numprim[i];
printf("%d\n",sum);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: