您的位置:首页 > 其它

poj 1611 The Suspects

2012-05-13 22:06 399 查看
The Suspects

Time Limit: 1000MSMemory Limit: 20000K
Total Submissions: 14417Accepted: 6855
Description

Severe acute respiratory syndrome (SARS), an atypical pneumonia of unknown aetiology, was recognized as a global threat in mid-March 2003. To minimize transmission to others, the best strategy is to separate the suspects from others.
In the Not-Spreading-Your-Sickness University (NSYSU), there are many student groups. Students in the same group intercommunicate with each other frequently, and a student may join several groups. To prevent the possible transmissions of SARS, the NSYSU collects the member lists of all student groups, and makes the following rule in their standard operation procedure (SOP).
Once a member in a group is a suspect, all members in the group are suspects.
However, they find that it is not easy to identify all the suspects when a student is recognized as a suspect. Your job is to write a program which finds all the suspects.
Input

The input file contains several cases. Each test case begins with two integers n and m in a line, where n is the number of students, and m is the number of groups. You may assume that 0 < n <= 30000 and 0 <= m <= 500. Every student is numbered by a unique integer between 0 and n−1, and initially student 0 is recognized as a suspect in all the cases. This line is followed by m member lists of the groups, one line per group. Each line begins with an integer k by itself representing the number of members in the group. Following the number of members, there are k integers representing the students in this group. All the integers in a line are separated by at least one space.
A case with n = 0 and m = 0 indicates the end of the input, and need not be processed.
Output

For each case, output the number of suspects in one line.
Sample Input

100 4
2 1 2
5 10 13 11 12 14
2 0 1
2 99 2
200 2
1 5
5 1 2 3 4 5
1 0
0 0

Sample Output

4
1
1

并查集的题
用最一般的方法做


#include<iostream>
using namespace std;

int father[30001];

void make_union(int x)
{
for(int i=0;i<=x;i++)
{
father[i]=i;
}
}

int find_father(int x)
{
if(father[x]!=x)
return find_father(father[x]);
return x;
}

void union_set(int a, int b)
{
father[a] = b;
}

int main()
{
int n, m;
int k;
int i, j;
int x, y;
//    freopen("e:\\data.txt", "r", stdin);
//    freopen("e:\\out.txt", "w", stdout);
while(cin>>n>>m)
{
if(n==0 && m==0)
break;
if(m == 0)
{
cout << "1\n";
continue;
}
make_union(n);
for(i=0;i<m;i++)
{
cin>>k;
cin>>x;
for(j=1;j<k;j++)
{
cin>>y;
int p = find_father(x);
int q = find_father(y);
if(p!=q)
union_set(p, q);
x = y;
}
}
int cnt=0;
int f = find_father(0);
for(i=0;i<n;i++)
{
if(find_father(i)==f)
cnt++;
}
cout<<cnt<<endl;
}
return 0;
}


非常慢。。。500+ms

改进,按秩合并

#include<iostream>
using namespace std;

int father[30001];
int num[30001];

void make_union(int x)
{
for(int i=0;i<=x;i++)
{
father[i]=i;
num[i]=1;
}
}

int find_father(int x)
{
if(father[x]!=x)
return find_father(father[x]);
return x;
}

void union_set(int a, int b)
{
/* 将小集合合并到大集合中,更新集合个数 */
if (num[a] <= num[b])
{
father[a] = b;
num[b] += num[a];
}
else
{
father[b] = a;
num[a] += num[b];
}
}

int main()
{
int n, m;
int k;
int i, j;
int x, y;
//    freopen("e:\\data.txt", "r", stdin);
//    freopen("e:\\out.txt", "w", stdout);
while(cin>>n>>m)
{
if(n==0 && m==0)
break;
if(m == 0)
{
cout << "1\n";
continue;
}
make_union(n);
for(i=0;i<m;i++)
{
cin>>k;
cin>>x;
for(j=1;j<k;j++)
{
cin>>y;
int p = find_father(x);
int q = find_father(y);
if(p!=q)
union_set(p, q);
x = y;
}
}
int cnt=0;
int f = find_father(0);
for(i=0;i<n;i++)
{
if(find_father(i)==f)
cnt++;
}
cout<<cnt<<endl;
}
return 0;
}


继续改进

#include <iostream>
using namespace std;

const int MAXN = 30001; /*结点数目上线*/
int pa[MAXN];    /*p[x]表示x的父节点*/
int rank[MAXN];    /*rank[x]是x的高度的一个上界*/
int num[MAXN];/*num[]存储该集合中元素个数,并在集合合并时更新num[]即可*/

void make_set(int x)
{/*创建一个单元集*/
pa[x] = x;
rank[x] = 0;
num[x] = 1;
}

int find_set(int x)
{/*带路径压缩的查找*/
/*保存待查找的数*/
int r = x, temp;
/*找到根节点*/
while(pa[r] != r) r = pa[r];
while(x != r)
{
temp = pa[x];
pa[x] = r;
x = temp;
}
return x;
//if(x != pa[x]) //注释掉的其实也是可以的,不过不想用递归来做啦
//    pa[x] = find_set(pa[x]);
//return pa[x];
}

/*按秩合并x,y所在的集合*/
void union_set(int x, int y)
{
x = find_set(x);
y = find_set(y);
if(x == y)return ;
if(rank[x] > rank[y])/*让rank比较高的作为父结点*/
{
pa[y] = x;
num[x] += num[y];
}
else
{
pa[x] = y;
if(rank[x] == rank[y])
rank[y]++;
num[y] += num[x];
}
}

//answer to 1611
int main()
{
int n, m, x, y, i, t, j;
//    freopen("e:\\data.txt", "r", stdin);
//    freopen("e:\\out.txt", "w", stdout);
while(scanf("%d%d", &n, &m))
{
if(m==n && n == 0) break;
if(m == 0)
{
cout << "1\n"; continue;
}
for(i = 0; i < n; i++)
make_set(i);
for(i = 0; i < m; i++)
{
scanf("%d", &t);
scanf("%d", &x);
for(j = 1; j < t; j++){
scanf("%d", &y);
union_set(x, y);
x = y;
}
}
x = find_set(0);/*找到0所在的树的树根*/
//int ans = 0;
//for(i = 0; i < n; i++)
//    if(pa[i] == x)
//        ans++;
//cout << ans << endl;
cout << num[x] << endl;
}
return 0;
}


算法无止境啊 还需学习~~~
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: