您的位置:首页 > 其它

B - Agri-Net解题报告(吴忠健)

2012-05-13 19:37 288 查看
B - Agri-Net
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d
& %I64u
Submit Status Practice POJ
1258

Description

Farmer John has been elected mayor of his town! One of his campaign promises was to bring internet connectivity to all farms in the area. He needs your help, of course.

Farmer John ordered a high speed connection for his farm and is going to share his connectivity with the other farmers. To minimize cost, he wants to lay the minimum amount of optical fiber to connect his farm to all the other farms.

Given a list of how much fiber it takes to connect each pair of farms, you must find the minimum amount of fiber needed to connect them all together. Each farm must connect to some other farm such that a packet can flow from any one farm to any other farm.

The distance between any two farms will not exceed 100,000.

Input

The input includes several cases. For each case, the first line contains the number of farms, N (3 <= N <= 100). The following lines contain the N x N conectivity matrix, where each element shows the distance from on farm to another. Logically, they are N lines
of N space-separated integers. Physically, they are limited in length to 80 characters, so some lines continue onto others. Of course, the diagonal will be 0, since the distance from farm i to itself is not interesting for this problem.

Output

For each case, output a single integer length that is the sum of the minimum length of fiber required to connect the entire set of farms.

Sample Input

4
0 4 9 21
4 0 8 17
9 8 0 16
21 17 16 0


Sample Output

28


题目大意:给出n个村庄之间的距离,要求把每个村庄都用网线联通,求连通后的网线的最小长度。

思路:最小生成树

解题代码:

#include<stdio.h>
const int Max=1000005;
int map[100][100];
int low[100];
int main()
{
int i,j,k,n,min;
while(scanf("%d",&n)!=EOF)
{
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
scanf("%d",&map[i][j]);//输入距离
}
for(i=0;i<n;i++)
low[i]=map[0][i];//先存第一行的距离,即此时的做短距离
k=n-1;//连通后的k条路
int ans=0;
while(k--)
{

int max=Max+1;
for(j=0;j<n;j++)
{
if(low[j]&&max>low[j])//判断每行中的非零且最小值
{
max=low[j];
min=j;
}
}
ans+=low[min];//最小权值相加
low[min]=0;将取过的点置零
for(j=0;j<n;j++)
{
if(low[j]>map[min][j])//min指明行数的改变,更改low的值
low[j]=map[min][j];
}
}
printf("%d\n",ans);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: