您的位置:首页 > 其它

poj 1979 Red and Black

2012-05-08 20:17 393 查看
Red and Black

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 16188Accepted: 8474
Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13


#include<iostream>
using namespace std;

char map[22][22];
int w, h;
int startx, starty;
int sum;
int dx[] = {1,-1,0,0};
int dy[] = {0,0,1,-1};

int judge(int a, int b)
{
if(a<0 || b<0 || a>=h || b>=w)
return 0;
return 1;
}

void dfs(int x, int y)
{
map[x][y] = '#';
int i;
for(i=0;i<4;i++)
{
int ax = x+dx[i];
int ay = y+dy[i];
if(judge(ax, ay) && map[ax][ay]=='.')
{
sum++;
dfs(ax, ay);
}
}
}

int main()
{
int i, j;
freopen("e:\\data.txt", "r", stdin);
freopen("e:\\out.txt", "w", stdout);
while(cin>>w>>h && w && h)
{
sum = 1;
for(i=0;i<h;i++)
{
for(j=0;j<w;j++)
{
cin>>map[i][j];
if(map[i][j] == '@')
{
startx = i;
starty = j;
}
}
}
dfs(startx, starty);
cout<<sum<<endl;
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: