您的位置:首页 > 其它

poj2499 Binary Tree

2012-05-04 17:09 483 查看
Description
Background

Binary trees are a common data structure in computer science. In this problem we will look at an infinite binary tree where the nodes contain a pair of integers. The tree is constructed like this:

The root contains the pair (1, 1).

If a node contains (a, b) then its left child contains (a + b, b) and its right child (a, a + b)

Problem

Given the contents (a, b) of some node of the binary tree described above, suppose you are walking from the root of the tree to the given node along the shortest possible path. Can you find out how often you have to go to a left child and how often to a right
child?
Input
The first line contains the number of scenarios.

Every scenario consists of a single line containing two integers i and j (1 <= i, j <= 2*109) that represent

a node (i, j). You can assume that this is a valid node in the binary tree described above.
Output
The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing two numbers l and r separated by a single space, where l is how
often you have to go left and r is how often you have to go right when traversing the tree from the root to the node given in the input. Print an empty line after every scenario.
Sample Input
3
42 1
3 4
17 73

Sample Output
Scenario #1:
41 0

Scenario #2:
2 1

Scenario #3:
4 6

Source
TUD Programming Contest 2005 (Training Session), Darmstadt, Germany

简单题,主要是hdu挂了所以随便在poj上找点刷的……orz。

题意很简单,一棵二叉树,树根是(1,1)。

如果某个节点是(a,b),则左孩纸是(a+b,b),右孩纸是(a,a+b)

给一个(x,y),问从树根走到该节点共往左走几步,往右走几步?

错了两次,一个是格式,一个是模拟,没有考虑复杂度,所以超时了,不能每次减,要用除的。

#include <stdio.h>

int a,b;

void Solve(int n,int m)
{
    int t;
    while(n!=1 || m!=1)
    {
        if (n==1)
        {
            b+=m-1;
            return;
        }
        if (m==1)
        {
            a+=n-1;
            return;
        }
        if (n>m)
        {
            t=n/m;
            a+=t;
            n=n-t*m;
        }
        else
        {
            t=m/n;
            b+=t;
            m=m-t*n;
        }
    }
}

int main()
{
    int i,j,T,n,m,cnt=1;
    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d",&n,&m);
        a=b=0;
        Solve(n,m);
        printf("Scenario #%d:\n",cnt++);
        printf("%d %d\n\n",a,b);
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: