您的位置:首页 > 其它

ZOJ Problem Set–1755 Clay Bully

2012-05-04 16:41 555 查看
Time Limit: 2 Seconds      Memory Limit: 65536 KB

Ms. Terry is a pre-school art teacher who likes to have her students work with clay. One of her assignments is to form a lump of clay into a block and then measure the dimensions of the block. However, in every class, there is always one child who insists on taking some clay from some other child. Since Ms. Terry always gives every child in a class the same amount of clay to begin with, you can write a program that helps Ms. Terry find the bully and victim after she measures each child's finished block. Input

There are one or more classes of students, followed by a final line containing only the value -1. Each class starts with a line containing an integer, n, which is the number of students in the class, followed by n lines of student information. Each line of student information consists of three positive integers, representing the dimensions of the clay block, followed by the student's first name. There can never be more than 9 students nor less than 2 students in any class. Each student's name is at most 8 characters. Ms. Terry always gives each student at most 250 cubic units of clay. There is exactly one bully and one victim in each class.

Output

For each class print a single line exactly as shown in the sample output.

Sample Input

3
10 10 2 Jill
5 3 10 Will
5 5 10 Bill
4
2 4 10 Cam
4 3 7 Sam
8 11 1 Graham
6 2 7 Pam
-1

Sample Output

Bill took clay from Will.
Graham took clay from Cam.

Source: Mid-Central USA 2003

#include<iostream>
#include<string>
using namespace std;
int main()
{
int students;
while(cin>>students && students != -1)
  {
int max = -1,
min = 250,
crt_x, crt_y, crt_z;
string max_name, min_name, crt_name;
while(students-- && cin>>crt_x>>crt_y>>crt_z>>crt_name)
    {
int crt = crt_x*crt_y*crt_z;
if(crt> max)
      {
max_name = crt_name;
max = crt;
}
if(crt < min)
      {
min_name = crt_name;
min = crt;
}
}
cout<<max_name<<" took clay from "<<min_name<<"."<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: