您的位置:首页 > 其它

poj 2485(最小生成树 Prim)

2012-05-03 15:45 375 查看
Highways

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 15109Accepted: 7034
Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They're planning to build some highways so that it will be possible
to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town
that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.

The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between
village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input
1

3
0 990 692
990 0 179
692 179 0


Sample Output
692


Hint

Huge input,scanf is recommended.

Source

POJ Contest,Author:Mathematica@ZSU

题目类型:最小生成树

题目描述:求最小生成树中,权值最大的边。

题目分析:Prim算法的特点是集合A中的边总是形成单棵树,树从任意顶点r开始形成,并逐渐生成,直至树覆盖了V种的所有的顶点

在每一步,一条连接了树A与G(A) = (V,A)中某一孤立顶点的轻边被加入到树A中。

代码如下:

#include <iostream>
#include <stdio.h>
#define V 501
#define M 65537
using namespace std;

int n;
int map[V][V];
int key[V];
bool visit[V];

int minKey(){
int min = M;
int pos = -1;
for(int i = 0; i < n; i++){
if( key[i] < min && !visit[i]){
min = key[i];
pos = i;
}
}
return pos;
}
void update(int pos){
for(int i = 0; i < n; i++){
if( !visit[i] && map[pos][i] < key[i]){
key[i] = map[pos][i];
}
}
}

int prim(){
int max = -1;

for(int i = 0; i < n;i++){
visit[i] = false;
}
visit[0] = true;
for(int i = 0; i < n;i++){
key[i] = map[0][i];
}
for(int i = 1; i <= n-1; i++){
int pos = minKey();
visit[pos] = true;
if(key[pos] > max) {
max = key[pos];
}
update(pos);
}
return max;

}

int main()
{
int t;
scanf("%d",&t);
while(t--){
scanf("%d",&n);
for(int i = 0; i < n; i++){
for(int j = 0; j < n; j++){
scanf("%d",&map[i][j]);
}
}
printf("%d\n",prim());
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: