您的位置:首页 > 产品设计 > UI/UE

UESTC Training for Data Structures——E

2012-05-02 21:21 453 查看
Problem E

Time Limit : 3000/1000ms (Java/Other) Memory Limit : 65535/32768K (Java/Other)
Total Submission(s) : 237 Accepted Submission(s) : 79

Font: Times New Roman | Verdana | Georgia

Font Size: ← →

Problem Description

Farmer John's cows have discovered that the clover growing along the ridge of the hill (which we can think of as a one-dimensional number line) in his field is particularly good.

Farmer John has N cows (we number the cows from 1 to N). Each of Farmer John's N cows has a range of clover that she particularly likes (these ranges might overlap). The ranges are defined by a closed interval [S,E].

But some cows are strong and some are weak. Given two cows: cowi and cowj, their favourite clover range is [Si, Ei] and [Sj, Ej]. If Si <= Sj and Ej <= Ei and Ei - Si > Ej - Sj, we say that cowi is stronger than cowj.

For each cow, how many cows are stronger than her? Farmer John needs your help!

Input

The input contains multiple test cases.

For each test case, the first line is an integer N (1 <= N <= 10^5), which is the number of cows. Then come N lines, the i-th of which contains two integers: S and E(0 <= S < E <= 10^5) specifying the start end location respectively of a range preferred by
some cow. Locations are given as distance from the start of the ridge.

The end of the input contains a single 0.

Output

For each test case, output one line containing n space-separated integers, the i-th of which specifying the number of cows that are stronger than cowi.

Sample Input

3
1 2
0 3
3 4
0


Sample Output

1 0 0


/*将线段[x1,x2]看成是平面上的点(x1,x2),然后求解每个点左上方包括正上方的点的数量
先对点按y方向从大到小排序,要是y相同的,按x从小到大排序,由于自己写这个排序的
话,很麻烦,于是又去学习了怎么用STL里面的qsort。然后就是用树状数组统计*/

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#define N 100005
using namespace std;
struct data
{
int x,y,id;
}a
;
int n,tree
,val
;
bool cmp1(data a, data b)  //比较函数
{
if(a.y!=b.y) return a.y>b.y;
return a.x<b.x;
}
void update(int pos, int x)  //更新树状数组
{
while(pos<N)
{
tree[pos]+=x;
pos+=pos&(-pos);
}
}
int read(int pos)  //读取树状数组中的值
{
int sum=0;
while(pos>0)
{
sum+=tree[pos];
pos-=pos&(-pos);
}
return sum;
}
int main()
{
while(scanf("%d",&n),n!=0)
{
memset(tree,0,sizeof(tree));
memset(val,0,sizeof(val));
for(int i=0;i<n;i++)
{
scanf("%d%d",&a[i].x,&a[i].y);
a[i].id =i;
a[i].x++;
a[i].y++;
}
sort(a,a+n,cmp1);  //对点进行排序
val[a[0].id]=read(a[0].x);
update(a[0].x,1);
for(int i=1;i<n;i++)
{
if(a[i].x==a[i-1].x && a[i].y==a[i-1].y) val[a[i].id]=val[a[i-1].id];
else val[a[i].id]=read(a[i].x);
update(a[i].x,1);
}
printf("%d",val[0]);
for(int i=1;i<n;i++) printf(" %d", val[i]);
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: