您的位置:首页 > 其它

POJ-1005 I Think I Need a Houseboat解题报告

2012-04-24 22:32 501 查看
Description

Fred Mapper is considering purchasing some land in Louisiana to build his house on. In the process of investigating the land, he learned that the state of Louisiana is actually
shrinking by 50 square miles each year, due to erosion caused by the Mississippi River. Since Fred is hoping to live in this house the rest of his life, he needs to know if his land is going to be lost to erosion.

After doing more research, Fred has learned that the land that is being lost forms a semicircle. This semicircle is part of a circle centered at (0,0), with the line that bisects the circle being the X axis. Locations below the X axis are in the water. The
semicircle has an area of 0 at the beginning of year 1. (Semicircle illustrated in the Figure.)



Input

The first line of input will be a positive integer indicating how many data sets will be included (N). Each of the next N lines will contain the X and Y Cartesian coordinates
of the land Fred is considering. These will be floating point numbers measured in miles. The Y coordinate will be non-negative. (0,0) will not be given.

Output

For each data set, a single line of output should appear. This line should take the form of: “Property N: This property will begin eroding in year Z.” Where N is the data
set (counting from 1), and Z is the first year (start from 1) this property will be within the semicircle AT THE END OF YEAR Z. Z must be an integer. After the last data set, this should print out “END OF OUTPUT.”

Sample Input

2

1.0 1.0

25.0 0.0


Sample Output

Property 1: This property will begin eroding in year 1.

Property 2: This property will begin eroding in year 20.

END OF OUTPUT.


Hint

1.No property will appear exactly on the semicircle boundary: it will either be inside or outside.

2.This problem will be judged automatically. Your answer must match exactly, including the capitalization, punctuation, and white-space. This includes the periods at the ends of the lines.

3.All locations are given in miles.
题目链接:http://poj.org/problem?id=1005
题目大意:每年侵蚀土地的面积为逐年面积增加50的半圆,给你一个点,求在哪年会被侵蚀。
题目思路:很简单,N年的侵蚀面为50*n,求出半径在比较点与原点的距离大小即可。
实现代码:
#include<cstdio>
#include<iostream>
#include<cmath>
using namespace std;
const double PI=3.1415926;
int main()
{
int n,z;
double x,y,len;
while(cin>>n)
{
for(int i=0;i<n;i++)
{
cin>>x>>y;
len=sqrt(x*x+y*y);
for(z=1;;z++)
{
if(len<=10*sqrt(z/PI))
break;
}
printf("Property %d: This property will begin eroding in year %d.\n",i+1,z);
}
cout<<"END OF OUTPUT."<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: