您的位置:首页 > 其它

HDU 2509 Be the Winner

2012-04-17 08:53 417 查看

^^^转载请注明出处,谢谢合作O(∩_∩)O~

Be the Winner

Let's consider m apples divided into n groups. Each group contains no more than 100 apples, arranged in a line. You can take any number of consecutive apples at one time.
For example "@@@" can be turned into "@@" or "@" or "@ @"(two piles). two people get apples one after another and the one who takes the last is
the loser. Fra wants to know in which situations he can win by playing strategies (that is, no matter what action the rival takes, fra will win).

[align=left]Input[/align]
You will be given several cases. Each test case begins with a single number n (1 <= n <= 100), followed by a line with n numbers, the number of apples in each pile. There is a blank line between cases.

[align=left]Output[/align]
If a winning strategies can be found, print a single line with "Yes", otherwise print "No".

[align=left]Sample Input[/align]

2 2 2 1 3

[align=left]Sample Output[/align]

No Yes

:此题是尼姆博弈:

#include<iostream>
using namespace std;
int a[110];
int main()
{
int n;
while(scanf("%d",&n)!=EOF)
{
int i;
int s=0;
int s1=0;
for(i=0;i<n;i++)
{
cin>>a[i];
s=s^a[i];
if(a[i]>=2)
s1++;
}
if(s==0)//奇异局势
{
if(s1>=2)cout<<"No"<<endl;
else
cout<<"Yes"<<endl;
}
else//非奇异局势
{
if(s1>=1)cout<<"Yes"<<endl;
else
cout<<"No"<<endl;
}
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: