您的位置:首页 > 其它

nyoj18 The Triangle(dp)

2012-04-14 00:50 330 查看

The Triangle

时间限制:1000 ms | 内存限制:65535 KB
难度:4

描述
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5
(Figure 1)
Figure 1 shows a number triangle. Write a program that calculates the highest sum of numbers passed on a route that starts at the top and ends somewhere on the base. Each step can go either diagonally down to the left or diagonally down to the right.

输入Your program is to read from standard input. The first line contains one integer N: the number of rows in the triangle. The following N lines describe the data of the triangle. The number of rows in the triangle is > 1 but <= 100. The numbers in the triangle, all integers, are between 0 and 99.输出Your program is to write to standard output. The highest sum is written as an integer.样例输入
5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

样例输出
30

分析:dp[i][j]=max{dp[i-1][j],dp[i-1][j-1]}+a[i][j] ;从上往下更新.
View Code

#include<iostream>
#define N 105
using namespace std;

int a

,dp

;

int main()
{
int n,i,j,min;
while(cin>>n)
{
for(i=1;i<=n;i++)
for(j=1;j<=i;j++)
{
cin>>a[i][j];
dp[i][j]=0;
}
dp[1][1]=a[1][1];
for(i=2;i<=n;i++)
{
dp[i][1]=a[i][1]+dp[i-1][1];
for(j=2;j<=i;j++)
{
min=dp[i-1][j-1]>dp[i-1][j]?dp[i-1][j-1]:dp[i-1][j];
dp[i][j]=a[i][j]+min;
}
}
int ans=0;
for(i=1;i<=n;i++)
if(ans<dp
[i])
ans=dp
[i];
cout<<ans<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: