您的位置:首页 > 其它

Palindrome POJ 1159 动态规划

2012-04-11 18:36 113 查看
Description

A palindrome is a symmetrical string, that is, a string read identically from left to right as well as from right to left. You are to write a program which, given a string, determines the minimal number of characters to be inserted into the string in order
to obtain a palindrome.

As an example, by inserting 2 characters, the string "Ab3bd" can be transformed into a palindrome ("dAb3bAd" or "Adb3bdA"). However, inserting fewer than 2 characters does not produce a palindrome.

Input

Your program is to read from standard input. The first line contains one integer: the length of the input string N, 3 <= N <= 5000. The second line contains one string with length N. The string is formed from uppercase letters from 'A' to 'Z', lowercase letters
from 'a' to 'z' and digits from '0' to '9'. Uppercase and lowercase letters are to be considered distinct.

Output

Your program is to write to standard output. The first line contains one integer, which is the desired minimal number.

Sample Input
5
Ab3bd


Sample Output
2

#include "stdio.h"
const int N=5010;
char s
;
int c

={0};
int n;
int min(int a,int b)
{
if(a<b)
return a;
else
return b;
}
int Dp(int i,int j)
{
if(i==j)
return 0;
if(i>j)
return 0;
if(c[i][j]!=0)
return c[i][j];
if(s[i]==s[j])
c[i][j]=Dp(i+1,j-1);
else
c[i][j]=min(Dp(i+1,j),Dp(i,j-1))+1;
return c[i][j];
}
int main()
{
scanf("%d",&n);
scanf("\n%s",s+1);
printf("%d\n",Dp(1,n));
return 0;
}


动态规划这是个很好的例子。做为我一个学习笔记。
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: