您的位置:首页 > 其它

N!解题报告

2012-04-07 13:22 288 查看

N!

[b]Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 30093 Accepted Submission(s): 8264

[/b]

Problem Description

Given an integer N(0 ≤ N ≤ 10000), your task is to calculate N!

Input

One N in one line, process to the end of file.

Output

For each N, output N! in one line.

Sample Input

1
2
3


Sample Output

1
2
6


Author

JGShining(极光炫影)

#include<stdio.h>
#include<iostream>
#include<string.h>
using namespace std;
const int maxn = 50000;
int f[maxn];
int main()
{
int i,j,n;
while(cin>>n)
{
memset(f,0,sizeof(f));
f[0]=1;

{
for(i=2;i<=n;i++)
{
int c=0;
for(j=0;j<maxn;j++)
{
int s=f[j]*i+c;
f[j]=s%10;
c=s/10;
}
}
for(j=maxn-1;j>=0;j--)
{
if(f[j])
break;
}
for(i=j;i>=0;i--)
{
cout<<f[i];
}
cout<<endl;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: