您的位置:首页 > 其它

HDU 1792 A New Change Problem(数学规律题,数论知识)

2012-04-05 22:48 519 查看

A New Change Problem

Time Limit: 5000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 533 Accepted Submission(s): 265


[align=left]Problem Description[/align]
Now given two kinds of coins A and B,which satisfy that GCD(A,B)=1.Here you can assume that there are enough coins for both kinds.Please calculate the maximal value that you cannot pay and the total number that you cannot pay.

[align=left]Input[/align]
The input will consist of a series of pairs of integers A and B, separated by a space, one pair of integers per line.

[align=left]Output[/align]
For each pair of input integers A and B you should output the the maximal value that you cannot pay and the total number that you cannot pay, and with one line of output for each line in input.

[align=left]Sample Input[/align]

2 3 3 4

[align=left]Sample Output[/align]

1 1 5 3

[align=left]Author[/align]
lcy

[align=left]Recommend[/align]
lcy

题目就是给了两个互质的数A,B。
A*x+B*y(x>=0,y>=0)
问最大不能表示的数,和不能表示的数的个数。

数论知识;
个数就是(A-1)*(B-1)/2;
最大不能表示的数就是 A*B-A-B;

所有的数可以分成A类,就是对A取模余0~A-1的。
·······
简要推导见:http://hi.baidu.com/qq258513813/blog/item/81c1d5c57e9ac7009d163da6.html

代码:

#include<stdio.h>
int main()
{
int A,B;
while(scanf("%d%d",&A,&B)!=EOF)
{
printf("%d %d\n",A*B-A-B,(A-1)*(B-1)/2);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: