您的位置:首页 > 其它

HDU 1335 Basically Speaking【进制转换】

2012-04-05 16:41 190 查看
[align=left]Problem Description[/align]
The Really Neato Calculator Company, Inc. has recently hired your team to help design their Super Neato Model I calculator. As a computer scientist you suggested to the company that it would be neato if this new calculator could convert among number bases. The company thought this was a stupendous idea and has asked your team to come up with the prototype program for doing base conversion. The project manager of the Super Neato Model I calculator has informed you that the calculator will have the following neato features:
It will have a 7-digit display.
Its buttons will include the capital letters A through F in addition to the digits 0 through 9.
It will support bases 2 through 16.
[align=left]Input[/align]
The input for your prototype program will consist of one base conversion per line. There will be three numbers per line. The first number will be the number in the base you are converting from. The second number is the base you are converting from. The third number is the base you are converting to. There will be one or more blanks surrounding (on either side of) the numbers. There are several lines of input and your program should continue to read until the end of file is reached.
[align=left]Output[/align]
The output will only be the converted number as it would appear on the display of the calculator. The number should be right justified in the 7-digit display. If the number is to large to appear on the display, then print "ERROR'' (without the quotes) right justified in the display.
[align=left]Sample Input[/align]

1111000 2 10 1111000 2 16 2102101 3 10 2102101 3 15 12312 4 2 1A 15 2 1234567 10 16 ABCD 16 15

[align=left]Sample Output[/align]

120 78 1765 7CA ERROR 11001 12D687 D071
分析: 从任意进制到任意进制。

View Code

#include<stdio.h>
#include<string.h>
int z1(char s[],int b)
{
int i,num=0;
for(i=0;s[i];i++)
{
if(s[i]>='A'&&s[i]<='Z')
num=num*b+(s[i]-'A')+10;
else num=num*b+s[i]-'0';
}
return num;
}
void print(int x,int b)
{
int s[1000];
int i,top=0;
while(x)
{
s[top++]=x%b;
x=x/b;
}
if(top<=7)
{
for(i=1;i<8-top;i++)
printf(" ");
for(i=top-1;i>=0;i--)
if(s[i]>=10)
printf("%c",'A'+s[i]-10);
else printf("%d",s[i]);
printf("\n");
}
else printf("  ERROR\n");
}
int main()
{
char s[1000];
int i,num;
int a,b;
while(scanf("%s%d%d",s,&a,&b)!=EOF)
{
num=z1(s,a);
print(num,b);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: