您的位置:首页 > 其它

SGU105 Div 3

2012-04-04 20:03 295 查看


105. Div 3

time limit per test: 0.5 sec.

memory limit per test: 4096 KB

There is sequence 1, 12, 123, 1234, ..., 12345678910, ... . Given first N elements of that sequence. You must determine amount of numbers in it that are divisible by 3.

Input
Input contains N (1<=N<=231 - 1).

Output
Write answer to the output.

Sample Input

4


Sample Output

2

用d[i]表示第i个数模3后的余数,则d[i+1] = d[i] + (i + 1) % 3,由此可得数组d的周期为3。
#include <cstdio>

int main()
{
int n;
while (scanf("%d", &n) != EOF)
{
int ans = 0;
if (n % 3 == 2)
ans++;
ans += 2 * (n / 3);
printf("%d\n", ans);
}
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: