您的位置:首页 > 其它

An Easy Problem!

2012-03-31 16:02 239 查看
Description

Have you heard the fact "The base of every normal number system is 10" ? Of course, I am not talking about number systems like Stern Brockot Number System. This problem has nothing to do with this fact
but may have some similarity.

You will be given an N based integer number R and you are given the guaranty that R is divisible by (N-1). You will have to print the smallest possible value for N. The range for N is 2 <= N <= 62 and the digit symbols for 62 based number is (0..9 and A..Z
and a..z). Similarly, the digit symbols for 61 based number system is (0..9 and A..Z and a..y) and so on.

Input

Each line in the input will contain an integer (as defined in mathematics) number of any integer base (2..62). You will have to determine what is the smallest possible base of that number for the given
conditions. No invalid number will be given as input. The largest size of the input file will be 32KB.

Output

If number with such condition is not possible output the line "such number is impossible!" For each line of input there will be only a single line of output. The output will always be in decimal number
system.

Sample Input

3
5
A


Sample Output

4
6
11

#include<stdio.h>
#include<string.h>

char a[100000];
int main()
{
int n=0,max=0,len,d,i;

while(gets(a))
{
max=0,n=0,d=0;
len=strlen(a);
for(i=0;i<len;i++)
{
if(a[i]>='0'&&a[i]<='9')
{
if(a[i]-'0'>max)
{
max=a[i]-'0';
}
n=n+a[i]-'0';
}

if(a[i]>='A'&&a[i]<='Z')
{
if(a[i]-'A'+10>max)
{
max=a[i]-'A'+10;
}
n=n+a[i]-'A'+10;
}

if(a[i]>='a'&&a[i]<='z')
{
if(a[i]-'a'+36>max)
{
max=a[i]-'a'+36;
}
n=n+a[i]-'a'+36;
}

}
for(i=2;i<=62;i++)
{
if(n%(i-1)==0&&max<i)
{
d=1;
break;
}
}
if(d==1)
printf("%d\n",i);
else
printf("such number is impossible!\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: