您的位置:首页 > 其它

poj-1840 Eqs

2012-03-28 23:20 357 查看
D -
Eqs
Crawling in process...Crawling failedTime
Limit:
5000MS Memory Limit:65536KB
64bit IO Format:%I64d & %I64u
SubmitStatusPracticePOJ
1840

Description

Consider equations having the following form:

a1x13+ a2x23+ a3x33+ a4x43+ a5x53=0

The coefficients are given integers from the interval [-50,50].

It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47


Sample Output

654

若是按照常规的做法从最小数一个个试的话,结果一定会超限。所以先计算几个数的值,放在hash表中,在计算另外的数的值,若两个值相减为0,就输出。

#include<iostream>
using namespace std;

short hash[25000001];

int main(void)
{
int a1,a2,a3,a4,a5;
while(cin>>a1>>a2>>a3>>a4>>a5)
{
memset(hash,0,sizeof(hash));

for(int x1=-50;x1<=50;x1++)
{
if(!x1)
continue;

for(int x2=-50;x2<=50;x2++)
{
if(!x2)
continue;
int sum=(a1*x1*x1*x1 + a2*x2*x2*x2)*(-1);
if(sum<0)
sum+=25000000;
hash[sum]++;
}
}

int solution=0;

for(int x3=-50;x3<=50;x3++)
{
if(!x3)
continue;
for(int x4=-50;x4<=50;x4++)
{
if(!x4)
continue;
for(int x5=-50;x5<=50;x5++)
{
if(!x5)
continue;
int sum=a3*x3*x3*x3 + a4*x4*x4*x4 + a5*x5*x5*x5;
if(sum<0)
sum+=25000000;
if(hash[sum])
solution+=hash[sum];
}
}
}

cout<<solution<<endl;
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: