您的位置:首页 > Web前端

J - Perfect Pth Powers解题报告

2012-03-26 20:59 381 查看
J - Perfect Pth Powers
Time Limit:1000MS Memory Limit:10000KB 64bit IO Format:%I64d
& %I64u
Submit Status

Description


We say that x is a perfect square if, for some integer b, x = b2. Similarly, x is a perfect cube if, for some integer b, x = b3. More generally, x is a perfect pth power
if, for some integer b, x = bp. Given an integer x you are to determine the largest p such that x is a perfect pth power.

Input

Each test case is given by a line of input containing x. The value of x will have magnitude at least 2 and be within the range of a (32-bit) int in C, C++, and Java. A line containing 0 follows the last test case.

Output

For each test case, output a line giving the largest integer p such that x is a perfect pth power.

Sample Input

17
1073741824
25
0


Sample Output

1
30
2


我发现写解题报告还是很有好处的,所以从今天起好好的写解题报告。

这个题目的大意就是给出一个数a,找到一个数的p次幂等于这个数,要求是p是最大的。

我首先将输入的数a开根号,因为除了1,p的最小的数就是2了(负数就另当别论了),然后取t=2~sqrt(a),求t的p次幂,因为t是从小到大,如果有p满足就一定是最大的,所以找到了p就马上退出,输出。

负数的话,还是先开根号,不过要注意的是负数的p一定是奇数哈,完了,有错误请纠正。

代码如下:

#include<stdio.h>
#include<math.h>
#include<iostream>
using namespace std;
int main()
{
long double a,i,j,p,sum,num;
while(cin>>a&&a!=0)
{
sum=1,num=1;
if(a>0)
{
for(i=2;i<=sqrt(a)+1;i++)//去根号a,缩小范围
{
for(j=2;;j++)
{
for(p=0;p<j;p++)//求i的j次幂
{
sum=sum*i;
}
if(sum==a)//判断是否满足
{
num=j;
goto end;//满足的话就退出
}
if(sum>a)
{
goto top;
}
sum=1;
}
top:			sum=1;
}
}
else
{
sum=1,num=1;
a=-a;
for(i=2;i<=sqrt(a)+1;i++)
{
for(j=3;;j+=2)//负数和正数不一样,只能为奇数
{
for(p=0;p<j;p++)
{
sum=sum*i;
}
if(sum==a)
{
num=j;
goto end;
}
if(sum>a)
{
goto top1;//不满足的话继续进行
}
sum=1;
}
top1:			sum=1;
}
}
end:;
cout<<num<<endl;
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: