您的位置:首页 > 其它

POJ_3278 Catch That Cow 解题报告

2012-03-16 01:21 507 查看
Catch That Cow

Time Limit: 2000MSMemory Limit: 65536K
Total Submissions: 28177Accepted: 8677
Description

Farmer John has been informed of the location of a fugitive cow and wants to catch her immediately. He starts at a point N (0 ≤ N ≤ 100,000) on a number line and the cow is at a point K (0 ≤ K ≤ 100,000) on the same number
line. Farmer John has two modes of transportation: walking and teleporting.

* Walking: FJ can move from any point X to the points X - 1 or X + 1 in a single minute

* Teleporting: FJ can move from any point X to the point 2 × X in a single minute.

If the cow, unaware of its pursuit, does not move at all, how long does it take for Farmer John to retrieve it?

Input

Line 1: Two space-separated integers: N and K

Output

Line 1: The least amount of time, in minutes, it takes for Farmer John to catch the fugitive cow.

Sample Input
5 17


Sample Output
4


Hint

The fastest way for Farmer John to reach the fugitive cow is to move along the following path: 5-10-9-18-17, which takes 4 minutes.

题目连接:http://poj.org/problem?id=3278

算法类型:BFS

解题思路:BFS搜索,标记已经访问的进行剪枝。

算法实现:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int vis[100000];    //记录是否访问过;
int dis[100000];    //记录步数;
int q[100000];      //队列;
int n,k;
int bfs(int n)         //广搜函数;
{
int rear=0 ,front=0,u;      //队列头和尾都为0;
vis
==1;
q[rear++]=n;          //入队列;
while(front<rear)    //队列不为空;
{
u=q[front++]; //出队列;
if(u==k)   // 当找到牛时就跳出;
break;
if(u*2<=100000 && vis[2*u]==0 && u*2>0)   //下面三个IF 是广搜的三个方向;
{
dis[u*2]=dis[u]+1;     //记录达到这点走过的步数;
q[rear++]=u*2;         //入队列;
vis[u*2]=1;
}
if(u+1<=100000 && vis[u+1]==0 && u+1>0)
{
dis[u+1]=dis[u]+1;
q[rear++]=u+1;
vis[u+1]=1;
}
if(u-1<=100000 && u-1>0 && vis[u-1]==0)
{
dis[u-1]=dis[u]+1;
q[rear++]=u-1;
vis[u-1]=1;
}

}
return 1;
}
int main()
{
while(scanf("%d%d",&n,&k)!=EOF)
{
memset(vis,0,sizeof(vis));    //置0函数;
memset(q,0,sizeof(q));
memset(dis,0,sizeof(dis));
if(k<=n)    //判断是人在前,还是牛在前;
{
printf("%d\n",n-k);     //  输出步数;
}
else
{
bfs(n);     //调用宽搜函数;
printf("%d\n",dis[k]);   //  输出步数;
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: