您的位置:首页 > 其它

HDU 2614 Beat【深搜】

2012-03-15 12:55 162 查看
Problem Description
Zty is a man that always full of enthusiasm. He wants to solve every kind of difficulty ACM problem in the world. And he has a habit that he does not like to solve
a problem that is easy than problem he had solved. Now yifenfei give him n difficulty problems, and tell him their relative time to solve it after solving the other one.
You should help zty to find a order of solving problems to solve more difficulty problem.
You may sure zty first solve the problem 0 by costing 0 minute. Zty always choose cost more or equal time’s problem to solve.
Input
The input contains multiple test cases.
Each test case include, first one integer n ( 2< n < 15).express the number of problem.
Than n lines, each line include n integer Tij ( 0<=Tij<10), the i’s row and j’s col integer Tij express after solving the problem i, will cost Tij minute to solve the problem j.
Output
For each test case output the maximum number of problem zty can solved.
Sample Input
3
0 0 0
1 0 1
1 0 0
3
0 2 2
1 0 1
1 1 0
5
0 1 2 3 1
0 0 2 3 1
0 0 0 3 1
0 0 0 0 2
0 0 0 0 0
Sample Output
3
2
4
题意:
给出N道题目,从0开始做,每做一题之后只能做耗时更多的题目,找出最多能做多少道题目;
分析:采用回溯的方法遍历每一种情况,找出其中做题最多的一个做题路线。
code:

View Code

#include<stdio.h>
#include<string.h>
int p[16][16];
int c[16];
int max;
int n;
void dfs(int row,int now,int tot)
{
int i;
int flag=1;
c[row]=1;
for(i=0;i<n;i++)
if(p[row][i]>=now&&!c[i])
flag=0;
if(flag)
{
if(max<tot)
max=tot;
c[row]=0;                  //深搜过程中要清除标记!
return;
}
for(i=0;i<n;i++)
if(p[row][i]>=now&&!c[i])
dfs(i,p[row][i],tot+1);
c[row]=0;                      //深搜过程中清除标记
}
int main()
{
int i,j,tot;
while(scanf("%d",&n)!=EOF)
{
memset(c,0,sizeof(c));
for(i=0;i<n;i++)
for(j=0;j<n;j++)
scanf("%d",&p[i][j]);
tot=1;
c[0]=1;
max=0;
for(i=1;i<n;i++)
dfs(i,p[0][i],tot+1);
printf("%d\n",max);
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: