您的位置:首页 > 其它

poj 2777 count color

2012-03-08 18:52 267 查看
额~~~好久没有一A过了啊~

Count Color

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 24726Accepted: 7341
Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem.

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment
with only one color. We can do following two operations on the board:

1. "C A B C" Color the board from segment A to segment B with color C.

2. "P A B" Output the number of different colors painted between segment A and segment B (including).

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the
beginning, the board was painted in color 1. Now the rest of problem is left to your.

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation
defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input
2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2


Sample Output
2
1


#include<stdio.h>
#include<string.h>
#define N 100001
#define L(i) i<<1
#define R(i) i<<1|1

struct node
{
int l,r,color;
int mid(){return (l+r)/2;}
}st[N<<2];
int vis[40];

void build(int l,int r,int id)
{
st[id].l=l;
st[id].r=r;
st[id].color=1;
if(l==r)
return ;
int mid=st[id].mid();
build(l,mid,L(id));
build(mid+1,r,R(id));
}
void push_down(int i)
{
st[L(i)].color=st[R(i)].color=st[i].color;
st[i].color=0;
}
void update(int l,int r,int k,int id)
{
if(st[id].l==l&&st[id].r==r)
{
st[id].color=k;
return ;
}
if(st[id].color)
push_down(id);
int mid=st[id].mid();
if(mid>=r)
update(l,r,k,L(id));
else if(mid<l)
update(l,r,k,R(id));
else
{
update(l,mid,k,L(id));
update(mid+1,r,k,R(id));
}
}
int query(int l,int r,int id)
{
if(st[id].color)
{
if(!vis[st[id].color])
{
vis[st[id].color]=1;
return 1;
}
return 0;
}
int mid=st[id].mid();
if(mid>=r)
return query(l,r,L(id));
else if(mid<l)
return query(l,r,R(id));
else
return query(l,mid,L(id))+query(mid+1,r,R(id));
}
int main()
{
int a,b,c,l,t,o;
char s[2];
scanf("%d%d%d",&l,&t,&o);
build(1,l,1);
while(o--)
{
scanf("%s",s);
if(s[0]=='C')
{
scanf("%d%d%d",&a,&b,&c);
update(a,b,c,1);
}
else
{
memset(vis,0,sizeof(vis));
scanf("%d%d",&a,&b);
printf("%d\n",query(a,b,1));
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: