您的位置:首页 > 编程语言 > PHP开发

ZOJ1002的解题报告

2012-02-28 11:46 316 查看
 
Fire Net
Time Limit: 2 Seconds     
Memory Limit: 65536 KB
Suppose that we have a square city with straight streets. A map of a city is a square board with n rows and n columns, each representing a street or a piece of wall.

A blockhouse is a small castle that has four openings through which to shoot. The four openings are facing North, East, South, and West, respectively. There will be one machine gun shooting through each opening.

Here we assume that a bullet is so powerful that it can run across any distance and destroy a blockhouse on its way. On the other hand, a wall is so strongly built that can stop the bullets.

The goal is to place as many blockhouses in a city as possible so that no two can destroy each other. A configuration of blockhouses is
legal provided that no two blockhouses are on the same horizontal row or vertical column in a map unless there is at least one wall separating them. In this problem we will consider small square cities (at most 4x4) that contain walls
through which bullets cannot run through.

The following image shows five pictures of the same board. The first picture is the empty board, the second and third pictures show legal configurations, and the fourth and fifth pictures show illegal configurations. For this board, the maximum number of
blockhouses in a legal configuration is 5; the second picture shows one way to do it, but there are several other ways.



Your task is to write a program that, given a description of a map, calculates the maximum number of blockhouses that can be placed in the city in a legal configuration.

The input file contains one or more map descriptions, followed by a line containing the number 0 that signals the end of the file. Each map description begins with a line containing a positive integer
n that is the size of the city; n will be at most 4. The next
n lines each describe one row of the map, with a '.' indicating an open space and an uppercase 'X' indicating a wall. There are no spaces in the input file.

For each test case, output one line containing the maximum number of blockhouses that can be placed in the city in a legal configuration.

Sample input:

4
.X..
....
XX..
....
2
XX
.X
3
.X.
X.X
.X.
3
...
.XX
.XX
4
....
....
....
....
0


Sample output:

5
1
5
2
4


这是一道搜索的题目。

题目分析:

由于地图的大小最大为4*4,那么我们就将地图用一个char数组存起来,即map[4][4]。如果map[i][j]='X'则表示地图此处存放的为墙,map[i][j]='.'则表示此处存放的为空地,而map[i][j]='o'则表示此处存放的为炮塔。

关键:炮塔不能同时在水平和垂直线上,除非有墙作为间隔。

我们定义k为位置,k=0即为地图左上方第一个格子。

依次如下所示:

如4*4的地图:

0  1  2  3

4  5 6  7

8  9  10  11

12 13 14 15

那么依次往其中放炮塔,判断两个条件:1.放的位置是否为空地2.同行同列不能够有炮塔,除非有墙间隔(见canput函数)

如果到了k=n*n即终止条件时,看目前的最大炮塔数是否大于bestn最优炮塔数。

这样搜索,即可得到最好的结果。

代码如下:

#include<stdio.h>
//城市的尺寸
int n;
//城市的地图,最多是4*4
char map[4][4];
//最多放的炮塔数
int bestn;
//看炮塔是否能够放置
int canput(int row,int col)
{
int i;
for(i=row-1;i>=0;i--)
{
if(map[i][col]=='X')
{
break;
}
if(map[i][col]=='o')
{
return 0;
}
}
for(i=col-1;i>=0;i--)
{
if(map[row][i]=='X')
{
break;
}
if(map[row][i]=='o')
{
return 0;
}
}
return 1;
}
//K表示放置炮塔的位置
void backtrack(int k,int current)
{
int x,y;
if(k>=n*n)
{
if(current>bestn)
{
bestn=current;
}
return;
}
else
{
x=k/n;
y=k%n;
if(map[x][y]=='.'&&canput(x,y))
{
map[x][y]='o';
backtrack(k+1,current+1);
map[x][y]='.';
}
backtrack(k+1,current);
}
}
void initial()
{
int i,j;
for(i=0;i<4;i++)
{
for(j=0;j<4;j++)
{
map[i][j]='.';
}
}
}
int main()
{
scanf("%d",&n);
while(n)
{
int i,j;
bestn=0;
initial();
for(i=0;i<n;i++)
{
for(j=0;j<n;j++)
{
char ch;
ch=getchar();
if(ch=='\n')
{
j--;
continue;
}
else
{
map[i][j]=ch;
}
}
}
backtrack(0,0);
printf("%d\n",bestn);
scanf("%d",&n);
}

return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息