您的位置:首页 > 大数据 > 人工智能

HDOJ 1239:Calling Extraterrestrial Intelligence Again 解题报告

2012-02-25 10:19 381 查看


Calling Extraterrestrial Intelligence Again

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 2905 Accepted Submission(s): 1561



Problem Description

A message from humans to extraterrestrial intelligence was sent through the Arecibo radio telescope in Puerto Rico on the afternoon of Saturday November 16, 1974. The message consisted of 1679 bits and was meant to be translated to a rectangular picture with
23 * 73 pixels. Since both 23 and 73 are prime numbers, 23 * 73 is the unique possible size of the translated rectangular picture each edge of which is longer than 1 pixel. Of course, there was no guarantee that the receivers would try to translate the message
to a rectangular picture. Even if they would, they might put the pixels into the rectangle incorrectly. The senders of the Arecibo message were optimistic.

We are planning a similar project. Your task in the project is to find the most suitable width and height of the translated rectangular picture. The term "most suitable" is defined as follows. An integer m greater than 4 is given. A positive fraction a / b
less than or equal to 1 is also given. The area of the picture should not be greater than m. Both of the width and the height of the translated picture should be prime numbers. The ratio of the width to the height should not be less than a / b nor greater
than 1. You should maximize the area of the picture under these constraints.

In other words, you will receive an integer m and a fraction a / b. It holds that m > 4 and 0 < a / b < 1. You should find the pair of prime numbers p, q such that pq <= m and a / b <= p / q <= 1, and furthermore, the product pq takes the maximum value among
such pairs of two prime numbers. You should report p and q as the "most suitable" width and height of the translated picture.

Input

The input is a sequence of at most 2000 triplets of positive integers, delimited by a space character in between. Each line contains a single triplet. The sequence is followed by a triplet of zeros, 0 0 0, which indicated the end of the input and should not
be treated as data to be processed.

The integers of each input triplet are the integer m, the numerator a, and the denominator b described above, in this order. You may assume 4 < m <= 100000 and 1 <= a <= b <= 1000.

Output

The output is a sequence of pairs of positive integers. The i-th output pair corresponds to the i-th input triplet. The integers of each output pair are the width p and the height q described above, in this order.

Each output line contains a single pair. A space character is put between the integers as a delimiter. No other characters should appear in the output.

Sample Input

5 1 2
99999 999 999
1680 5 16
1970 1 1
2002 4 11
0 0 0


Sample Output

2 2
313 313
23 73
43 43
37 53


题目简意:根据给定的m、a、b 输出尽可能大的质数p和q 使得p*q<=m且p/q>=a/b

#include "StdAfx.h"
#include <fstream>
#include <iostream>
#include <cmath>
using namespace std;
bool isPrime[10000]={0};
int prime[10000];
int num=0;
void init(){
memset( isPrime, 0, sizeof(isPrime) );
int i, j;
double d=sqrt(10000*1.0);
for( i=2; i<=d; i++)
for( j=2; j*i<10000; j++)
isPrime[i*j]=1;
for( i=2; i<10000; i++ )
if(!isPrime[i]){
prime[num] = i;
num++;
}
};

int main()
{
ifstream cin("1239_input.txt");	//调试用
int n, i, j;	//t=test cases
int m, a, b, p, q;	//p和q都为prime number[质数]
init();
while ( cin >> m >> a >> b && m!=0 ){
float aspect = a*1.0/b;
int product, final = 0;	//product=乘积
for( i=num-1; i>=0; i-- ){
for( j=num-1; j>=i; j--){
product = prime[i]*prime[j];
if( product<=m && prime[i]*1.0/prime[j]>=aspect ){
if( product>final ){
final = product;
p = prime[i];
q = prime[j];
}
break;
}
}
}
cout << p << " " << q << endl;
}//while
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: