您的位置:首页 > 其它

POJ 3386 Halloween Hoildays(我的水题之路——两个戒指)

2012-02-14 19:52 344 查看
Halloween Holidays

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 2787Accepted: 1120
Description

Planet Cucurbita is inhabited with intelligent pumpkins. These pumpkins are not only extremely clever, they also are fond of tourism. One of their main routes is the Earth during Halloween.

As you know, pumpkins cannot move by themselves (intelligent pumpkins are not an exception), so they make somebody else to transport them. In the case of Halloween this is done by humans. First, they make people to grow special biological docking stations,
then prepare the stations (people cut special holes, fire candles etc – you know the procedure), and after these preparations pumpkins come and have fun. People usually do not see anything and think that this is just a holiday and that this holiday is for
humans, but remember – if somebody is frightened at Halloween, he was frightened not by his not-very-friendly friends, but by alien pumpkins.

To use the biological docking station, a pumpkin must have a special transmitter. It’s main elements are two rings made of gold and for some unexplainable reasons these rings should be cut from one round plate. The sizes of these rings (inner and outer radii)
are pumpkin-specific, so each alien should order a special set for himself.

Mr. Calabaza, an adolescent pumpkin, wants to make his first trip to the Earth. He found a discount plate, which was not redeemed by a previous customer, and it is necessary to check, whether this plate allows Mr. Calabaza to cut the rings he needs from
it, or he should order a new larger plate.

Input

The input file contains five integer numbers A, a, B, b, P (0 < A, a, B, b, P ≤ 1 000 000, a < A and b < B), separated
with spaces. Here, A and B are the outer radii of the rings, a and b are the inner radii of the corresponding rings, and P is the plate radius.

Output

Output a word “Yes” if the plate suits Mr. Calabaza, or a word “No” if he needs to order another one.

Sample Input
2 1 5 3 6


Sample Output
Yes


Hint



Source

Northeastern Europe 2006, Northern Subregion

需要在一个半径为P的金盘上扣下两个圆环做戒指,两个戒指的外半径分别为A、B,内半径分别为a、b。问是否可以在这个金盘上得到这两个戒指。

根据Hint里的图,知道两个戒指是套在一起的,所以只需要比较是否里面戒指的外半径小于外部戒指的内半径,外部戒指的外半径是是否小于金盘外半径,或者,两个外半径相加小于金盘半径(两个戒指并排)。

代码(1AC):

#include <cstdio>
#include <cstdlib>

int main(void){
int A, a, B, b, P;

while (scanf("%d%d%d%d%d", &A, &a, &B, &b, &P) != EOF){
if (A <= b && B <= P || B <= a && A <= P || A + B <= P){
printf("Yes\n");
}
else{
printf("No\n");
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: