您的位置:首页 > 其它

HDU 2007-11 Programming Contest_WarmUp

2012-02-01 14:38 309 查看
HDU 2131 Probability(水题)

Probability

Time Limit: 3000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 2313 Accepted Submission(s): 1146



[align=left]Problem Description[/align]
Mickey is interested in probability recently. One day , he played a game which is about probability with mini.First mickey gives a letter and a word to mini.Then mini calculate the probability that the letter appears in the word.For
example,give you the letter "a" and the word "apple". the probability of this case is 0.20000.

[align=left]Input[/align]
The input contains several test cases. Each test case consists of a letter and a word.The length of the word is no longer than 200.

[align=left]Output[/align]
For each test case, print the probability rounded to five digits after the decimal point.

[align=left]Sample Input[/align]

a apple c Candy a banana

[align=left]Sample Output[/align]

0.20000 0.20000 0.50000

[align=left]Author[/align]
KiKi

[align=left]Source[/align]
HDU 2007-11 Programming Contest_WarmUp

[align=left]Recommend[/align]
威士忌

#include<stdio.h>
#include<string.h>
char str[210];
int main()
{
char ch1,ch2;
while(scanf("%c %s",&ch1,&str)!=EOF)
{
if(ch1>='a'&&ch1<='z')ch2=ch1-'a'+'A';
else ch2=ch1-'A'+'a';
int len=strlen(str);
int tt=0;
for(int i=0;i<len;i++)
{
if(str[i]==ch1||str[i]==ch2)tt++;
}
printf("%.5lf\n",(double)tt/len);
getchar();
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: