您的位置:首页 > Web前端

POJ 1543 Perfect Cubes(我的水题之路——四重暴力水)

2012-01-30 18:31 429 查看
Perfect Cubes

Time Limit: 1000MSMemory Limit: 10000K
Total Submissions: 10707Accepted: 5739
Description

For hundreds of years Fermat's Last Theorem, which stated simply that for n > 2 there exist no integers a, b, c > 1 such that a^n = b^n + c^n, has remained elusively unproven. (A recent proof is believed to be correct, though it is still undergoing scrutiny.)
It is possible, however, to find integers greater than 1 that satisfy the "perfect cube" equation a^3 = b^3 + c^3 + d^3 (e.g. a quick calculation will show that the equation 12^3 = 6^3 + 8^3 + 10^3 is indeed true). This problem requires that you write a program
to find all sets of numbers {a,b,c,d} which satisfy this equation for a <= N.

Input

One integer N (N <= 100).

Output

The output should be listed as shown below, one perfect cube per line, in non-decreasing order of a (i.e. the lines should be sorted by their a values). The values of b, c, and d should also be listed in non-decreasing order on the line itself. There do exist
several values of a which can be produced from multiple distinct sets of b, c, and d triples. In these cases, the triples with the smaller b values should be listed first.

Sample Input
24


Sample Output
Cube = 6, Triple = (3,4,5)
Cube = 12, Triple = (6,8,10)
Cube = 18, Triple = (2,12,16)
Cube = 18, Triple = (9,12,15)
Cube = 19, Triple = (3,10,18)
Cube = 20, Triple = (7,14,17)
Cube = 24, Triple = (12,16,20)


Source

Mid-Central USA 1995

要求寻找N(N<=100)以下的,a^3=b^3+c^3+d^3的所有组合。要求按照以a为升序输出,同时,(b,c,d)中必须有b<=c<=d

四重暴力,不解释。

注意点:

1)如果四重暴力时候,上限均取为100,那么在查找数组的时候,循环条件如果是A<=N,必须考虑到N=100的情况

代码(1AC):

#include <cstdio>
#include <cstdlib>

int answer[100][4];
int top = 0;

void initsolve(){
int i, j;
int a, b, c, d;

for (a = 2; a <= 100; a++){
for (b = 2; b <= 100; b++){
for (c = b; c <= 100; c++){
for (d = c; d <= 100; d++){
if (a * a * a == b * b * b + c * c * c + d * d * d){
answer[top][0] = a;
answer[top][1] = b;
answer[top][2] = c;
answer[top][3] = d;
top++;
//printf("a=%d, b=%d, c=%d, d=%d\n", a, b, c, d);
}
}
}
}
}
}

int main(void){
int N;
int i;

initsolve();
while (scanf("%d", &N) != EOF){
for (i = 0; i < top && answer[i][0] <= N; i++){
printf("Cube = %d, Triple = (%d,%d,%d)\n", answer[i][0], answer[i][1], answer[i][2], answer[i][3]);
}
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: