您的位置:首页 > 其它

1395. Rounders

2012-01-27 00:12 183 查看
Time Limit: 1sec Memory Limit:32MB

Description

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100)

take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number

and round it to the nearest thousand, and so on ...

Input

Input to this problem will begin with a line containing a single integer n indicating the number of integers to

round. The next n lines each contain a single integer x (0 <= x <= 99999999).

Output

For each integer in the input, display the rounded integer on its own line.

Note: Round up on fives.

Sample Input


Copy sample
input to clipboard

9
15
14
4
5
99
12345678
44444445
1445
446


Sample Output

20
10
4
5
100
10000000
50000000
2000
500


#include <iostream>
#include <cmath>
using namespace std;

int main()
{
	int cases;
	cin>>cases;
	while(cases--)
	{
		int a,duplicate,mark=1;
		cin>>a;
		if(a<=10)
		{
			cout<<a<<endl;
			continue;
		}
		duplicate=a;
		while(true)
		{
			int temp=duplicate%10,tens=pow(10.0,mark);;
			if(temp>=5) a=(a/tens+1)*tens;
			else a=(a/tens)*tens;
			//if(duplicate/10==0) break;
			duplicate=a;
			duplicate/=tens;
			if(duplicate/10==0) break;
			mark++;
		}
		cout<<a<<endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: