您的位置:首页 > 其它

POJ1298解题报告

2012-01-13 13:35 393 查看
 
The Hardest Problem Ever

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 17404 Accepted: 9598
Description
Julius Caesar lived in a time of danger and intrigue. The hardest situation Caesar ever faced was keeping himself alive. In order for him to survive, he decided to create one of the first ciphers. This cipher was so incredibly
sound, that no one could figure it out without knowing how it worked.

You are a sub captain of Caesar's army. It is your job to decipher the messages sent by Caesar and provide to your general. The code is simple. For each letter in a plaintext message, you shift it five places to the right to create the secure message (i.e.,
if the letter is 'A', the cipher text would be 'F'). Since you are creating plain text out of Caesar's messages, you will do the opposite:

Cipher text

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Plain text

V W X Y Z A B C D E F G H I J K L M N O P Q R S T U

Only letters are shifted in this cipher. Any non-alphabetical character should remain the same, and all alphabetical characters will be upper case.

Input
Input to this problem will consist of a (non-empty) series of up to 100 data sets. Each data set will be formatted according to the following description, and there will be no blank lines separating data sets. All characters will
be uppercase.

A single data set has 3 components:

Start line - A single line, "START"

Cipher message - A single line containing from one to two hundred characters, inclusive, comprising a single message from Caesar

End line - A single line, "END"

Following the final data set will be a single line, "ENDOFINPUT".

Output
For each data set, there will be exactly one line of output. This is the original message by Caesar.

Sample Input
START
NS BFW, JAJSYX TK NRUTWYFSHJ FWJ YMJ WJXZQY TK YWNANFQ HFZXJX
END
START
N BTZQI WFYMJW GJ KNWXY NS F QNYYQJ NGJWNFS ANQQFLJ YMFS XJHTSI NS WTRJ
END
START
IFSLJW PSTBX KZQQ BJQQ YMFY HFJXFW NX RTWJ IFSLJWTZX YMFS MJ
END
ENDOFINPUT

Sample Output
IN WAR, EVENTS OF IMPORTANCE ARE THE RESULT OF TRIVIAL CAUSES
I WOULD RATHER BE FIRST IN A LITTLE IBERIAN VILLAGE THAN SECOND IN ROME
DANGER KNOWS FULL WELL THAT CAESAR IS MORE DANGEROUS THAN HE

这道题目的名字蛮好笑,最难的题目-----呵呵,其实是最简单的字符串问题

不过,注意一下scanf("%s",c)和gets(s)的区别,一个是按空格隔开读取,一个则是读取一整行。

 

#include<stdio.h>
#include<limits.h>
#include<string.h>
#define MAXNUM 100
#define LEN 26
const char ciper[]={'A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z'};
const char plain[]={'V','W','X','Y','Z','A','B','C','D','E','F','G','H','I','J','K','L','M','N','O','P','Q','R','S','T','U'};
char input1[MAXNUM];
int main()
{
scanf("%s",input1);
int len;
int i,j,tag;
//判断是否结束输入
while(strcmp(input1,"ENDOFINPUT")!=0)
{
if(strcmp(input1,"START")==0)
{
}
else if(strcmp(input1,"END")==0)
{
printf("\n");
}
else
{
len=strlen(input1);

for(i=0;i<len;i++)
{
tag=1;
for(j=0;j<LEN&&tag;j++)
{
if(ciper[j]==input1[i])
{
input1[i]=plain[j];
tag=0;
}
}
}

printf("%s",input1);
}
gets(input1);
}
system("pause");
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息