您的位置:首页 > 产品设计 > UI/UE

1209. Sequence Sum Possibi

2012-01-06 18:14 302 查看


1209. Sequence Sum Possibi


Description

Most positive integers may be written as a sum of a sequence of at least two consecutive positive integers. For instance,

6 = 1 + 2 + 3

9 = 5 + 4 = 2 + 3 + 4

but 8 cannot be so written.

Write a program which will compute how many different ways an input number may be written as a sum of a sequence of at least two consecutive positive integers.


Input

The first line of input will contain the number of problem instances N on a line by itself, (1<=N<=1000) . This will be followed by N lines, one for each problem instance. Each problem line will have the problem number, a single space and the number to be
written as a sequence of consecutive positive integers. The second number will be less than 2^31 (so will fit in a 32-bit integer).


Output

The output for each problem instance will be a single line containing the problem number, a single space and the number of ways the input number can be written as a sequence of consecutive positive integers.


Sample Input


7 
1 6 
2 9 
3 8 
4 1800 
5 987654321 
6 987654323 
7 987654325


Sample Output


1 1 
2 2 
3 0 
4 8 
5 17 
6 1 
7 23


纯数学题。

1.

设 n+.. +(n+k)=X, n>0,k>0

有 (2n+k)(k+1)=2X

k(k+1) <2X

k^2<2X

k<sqrt(2X)

枚举k到sqrt(2X)就行了

2.

假设num = (a + 0) + (a + 1) + ... + (a + i - 1) 其中i个数,则

num = i * a + 1 + 2 + ... + i - 1 = a*i + (i - 1) * i / 2

故num - (i - 1) * i / 2 = a * i

a为整数,num - (i - 1) * i / 2可被i整除

#include<iostream>
using namespace std;
int main()
{
	int n;
	cin>>n;
	int case_index;
	int num;
	for(int i=1;i<=n;i++)
	{
		int count=0;
		cin>>case_index>>num;
		for(int j=2; (j+1)*j <= 2*num;j++)
		{
			if((num-(j-1)*j/2) % j == 0)
			{
				count++;
			}
		}
		cout<<i<<" "<<count<<endl;
	}
	return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: