您的位置:首页 > 其它

poj 1971 Parallelogram Counting

2011-12-17 09:45 295 查看
Parallelogram Counting
Time Limit: 5000MSMemory Limit: 65536K
Total Submissions: 5130Accepted: 1699
DescriptionThere are n distinct points in the plane, given by their integer coordinates. Find the number of parallelograms whose vertices lie on these points. In other words, find the number of 4-element subsets of these points that can be written as {A, B, C, D} such that AB || CD, and BC || AD. No four points are in a straight line.
InputThe first line of the input contains a single integer t (1 <= t <= 10), the number of test cases. It is followed by the input data for each test case.
The first line of each test case contains an integer n (1 <= n <= 1000). Each of the next n lines, contains 2 space-separated integers x and y (the coordinates of a point) with magnitude (absolute value) of no more than 1000000000.
OutputOutput should contain t lines.
Line i contains an integer showing the number of the parallelograms as described above for test case i.
Sample Input
2
6
0 0
2 0
4 0
1 1
3 1
5 1
7
-2 -1
8 9
5 7
1 1
4 8
2 0
9 8

Sample Output
5
6
#include<iostream>
#include<algorithm>
using namespace std;

struct node
{
int x;
int y;
};
node plane[1001];
node middle[500000];

int comp(node a,node b)
{
if(a.x==b.x)
return a.y<b.y;
return a.x<b.x;
}
int main()
{
int cases;
int n;
int i,j,k;
int sum;
int total;
int flag;
//    freopen("E:\\c++\\oj\\t.txt","rt",stdin);
cin>>cases;
while(cases--)
{
cin>>n;
for(i=0;i<n;i++)
{
cin>>plane[i].x>>plane[i].y;
}
k=0;
for(i=0;i<n-1;i++)
{
for(j=i+1;j<n;j++)
{
middle[k].x=plane[i].x+plane[j].x;
middle[k].y=plane[i].y+plane[j].y;
k++;
}
}
sort(middle,middle+k,comp);
flag=0;
total=0;
sum=1;
for(i=1;i<k;i++)
{
if(middle[i].x==middle[flag].x && middle[i].y==middle[flag].y)
{
sum++;
}
else
{
flag=i;
total+=sum*(sum-1)/2;
sum=1;
}
}
cout<<total<<endl;
}
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: