您的位置:首页 > 其它

2405. Mirror, Mirror on the Wall

2011-12-13 22:13 204 查看


2405. Mirror, Mirror on the Wall


Description

For most fonts, the lowercase letters b and d are mirror images of each other, as are the letters p and q. Furthermore, letters i, o, v, w, and x are naturally
mirror images of themselves. Although other symmetries exists for certain fonts, we consider only those specifically mentioned thus far for the remainder of this problem.
Because of these symmetries, it is possible to encode certain words based upon how those words would appear in the mirror. For example the word boxwood would appear as boowxod, and the word ibid as bidi. Given a particular
sequence of letters, you are to determine its mirror image or to note that it is invalid.


Input

The input contains a series of letter sequences, one per line, followed by a single line with the # character. Each letter sequence consists entirely of lowercase letters.


Output

For each letter sequence in the input, if its mirror image is a legitimate letter sequence based upon the given symmetries, then output that mirror image. If the mirror image does not form a legitimate sequence of characters, then output the
word INVALID.


Sample Input


boowxod
bidi
bed
bbb
#


Sample Output


boxwood
ibid
INVALID
ddd


Problem Source

每周一赛第四场

// source code of submission 964045, Zhongshan University Online Judge System
#include <iostream>
#include <string>
#include <cstring>
using namespace std;

int main()
{
    string str;
    while (cin >> str)
    {
        if (str == "#")
            return 0;
        int len = str.length();
        bool b = true;
        for (int i = 0; i < len;i++)
        {
            if(str[i] == 'b')
                str[i] = 'd';
            else if(str[i] == 'd')
                str[i] = 'b';
            else if(str[i] == 'p')
                str[i] = 'q';
            else if(str[i] == 'q')
                str[i] = 'p';
            else if(str[i]!='i'&&str[i]!='o'&&str[i]!='v'&&str[i]!='w'&&str[i]!='x')
                 b = false;
        }
        if (b)
        {
            for (int j = len - 1;j >= 0;j--)
                cout << str[j];
            cout << endl;
        }
        else cout << "INVALID" << endl;
    }
    return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: