您的位置:首页 > 其它

hdu 1020

2011-12-13 20:51 204 查看

Encoding

[b]Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 12989 Accepted Submission(s): 5502

[/b]

[align=left]Problem Description[/align]
Given a string containing only 'A' - 'Z', we could encode it using the following method:

1. Each sub-string containing k same characters should be encoded to "kX" where "X" is the only character in this sub-string.

2. If the length of the sub-string is 1, '1' should be ignored.

[align=left]Input[/align]
The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only 'A' - 'Z' and the length is less than 10000.

[align=left]Output[/align]
For each test case, output the encoded string in a line.

[align=left]Sample Input[/align]

2
ABC
ABBCCC


[align=left]Sample Output[/align]

ABC
A2B3C


#include<string.h>

#include<stdio.h>

int main ()

{

int t ;

char str[10005];

while( scanf("%d" , &t ) != EOF )

{

while( t-- )

{

scanf("%s" , str);

int len = strlen ( str );

for( int i = 0 ; i < len ; i++ )

{

int hh = 1 ;

for( int j = i+1 ; j < len ; j++ )

if( str[i] == str[j] )hh++;

else break;

if( hh > 1 )

printf("%d%c", hh , str[i] );

else

printf("%c" , str[i]);

i +=(hh-1);//从下一个不重复的字母开始

}

puts("");

}

}

return 0;

}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: