您的位置:首页 > 其它

hdu 1022

2011-12-02 14:25 253 查看
关于举办HDU第11届大学生程序设计竞赛的通知(*有奖品*)

关于举办——2011百校联动“菜鸟杯”程序设计公开赛的倡议(需要注册)~

杭电2010和2011级同学如何加入ACM集训队?


Train Problem I

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)

Total Submission(s): 7791 Accepted Submission(s): 2855



[align=left]Problem Description[/align]
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes
a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves,
train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your
task is to determine whether the trains can get out in an order O2.







[align=left]Input[/align]
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file.
More details in the Sample Input.

[align=left]Output[/align]
The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out"
for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.

[align=left]Sample Input[/align]

3 123 321
3 123 312


[align=left]Sample Output[/align]

Yes.
in
in
in
out
out
out
FINISH
No.
FINISH

Hint#include<iostream>
#include<stack>
#include<string>
#include<cstring>
using namespace std;
int main()
{
stack<char> s;
string str2[1000],str,str1;
int n;
int i,j,k;

while(cin>>n>>str>>str1)
{
i=0;j=0;k=0;
while(!s.empty())s.pop();
while(i<n)
{
if(!s.empty()&&s.top()==str1[i])
{
s.pop();
str2[k++]="out";
i++;
}
else
{
if(j<n)
{
s.push(str[j]);
j++;
str2[k++]="in";
}
else
{
break;
}
}
}
if(!s.empty())
{
cout<<"No."<<endl<<"FINISH"<<endl;
}
else
{
cout<<"Yes."<<endl;
for( i=0; i<k; i++ )
{

cout<<str2[i]<<endl;
}
cout<<"FINISH"<<endl;
}

}
return 0;
}


内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: