您的位置:首页 > 其它

poj 1787 多重背包记录路径

2011-11-27 11:32 330 查看
第一道记录路径的题目Charlie's Change
Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 1998Accepted: 476
DescriptionCharlie is a driver of Advanced Cargo Movement, Ltd. Charlie drives a lot and so he often buys coffee at coffee vending machines at motorests. Charlie hates change. That is basically the setup of your next task.Your program will be given numbers and types of coins Charlie has and the coffee price. The coffee vending machines accept coins of values 1, 5, 10, and 25 cents. The program should output which coins Charlie has to use paying the coffee so that he uses as many coins as possible. Because Charlie really does not want any change back he wants to pay the price exactly.
InputEach line of the input contains five integer numbers separated by a single space describing one situation to solve. The first integer on the line P, 1 <= P <= 10 000, is the coffee price in cents. Next four integers, C1, C2, C3, C4, 0 <= Ci <= 10 000, are the numbers of cents, nickels (5 cents), dimes (10 cents), and quarters (25 cents) in Charlie's valet. The last line of the input contains five zeros and no output should be generated for it.
OutputFor each situation, your program should output one line containing the string "Throw in T1 cents, T2 nickels, T3 dimes, and T4 quarters.", where T1, T2, T3, T4 are the numbers of coins of appropriate values Charlie should use to pay the coffee while using as many coins as possible. In the case Charlie does not possess enough change to pay the price of the coffee exactly, your program should output "Charlie cannot buy coffee.".
Sample Input
12 5 3 1 2
16 0 0 0 1
0 0 0 0 0

Sample Output
Throw in 2 cents, 2 nickels, 0 dimes, and 0 quarters.
Charlie cannot buy coffee.

View Code
#include<stdio.h>
#include<string.h>
int v[4]={1,5,10,25};
int dp[10010];
int p[10010],used[10010];
int num[4],ans[30];
int main()
{
int m,i,j;
while(scanf("%d",&m)!=EOF)
{
int sum=m;
for(i=0;i<4;i++)
{
scanf("%d",&num[i]);
sum+=num[i];
}
if(sum==0) break;
memset(dp,0,sizeof(dp));
memset(p,0,sizeof(p));
p[0]=-1;dp[0]=1;
for(i=0;i<4;i++)
{
memset(used,0,sizeof(used));
for(j=v[i];j<=m;j++)
if((!dp[j]||dp[j-v[i]]+1>dp[j])&&dp[j-v[i]]&&used[j-v[i]]<num[i])
{
dp[j]=dp[j-v[i]]+1;
used[j]=used[j-v[i]]+1;
p[j]=j-v[i];
}
}
memset(ans,0,sizeof(ans));
if(dp[m])
{
i=m;
while(1)
{
if(p[i]==-1) break;
ans[i-p[i]]++;
i=p[i];
}
printf("Throw in %d cents, %d nickels, %d dimes, and %d quarters.\n",ans[1],ans[5],ans[10],ans[25]);
}
else printf("Charlie cannot buy coffee.\n");
}
return 0;
}

                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: