您的位置:首页 > 其它

uva490 Rotating Sentences

2011-11-24 23:57 309 查看



Rotating Sentences

In ``Rotating Sentences,'' you are asked to rotate a series of input sentences 90 degrees clockwise. So instead of displaying the input sentences from left to right and top to bottom, your program will display them
from top to bottom and right to left.

Input and Output

As input to your program, you will be given a maximum of 100 sentences, each not exceeding 100 characters long. Legal characters include: newline, space, any punctuation characters, digits, and lower case or upper
case English letters. (NOTE: Tabs are not legal characters.)

The output of the program should have the last sentence printed out vertically in the leftmost column; the first sentence of the input would subsequently end up at the rightmost column.

Sample Input

Rene Decartes once said,

"I think, therefore I am."

Sample Output

"R

Ie

n

te

h

iD

ne

kc

,a

r

tt

he

es

r

eo

fn

oc

re

e

s

Ia

i

ad

m,

.

"

fgets() 吃了换行 很难发现的错误,导致最后一行输出隔了个空行
#include <stdio.h>
#include <string.h>
#define MAX 105

char set[MAX][MAX];

int main()
{
int i, j, count = 0, length_max = 0;
for ( ;fgets(set[count], MAX, stdin); count++)
{
if ((i = strlen(set[count])) > length_max)
length_max = i;
}
for (i = 0; i < length_max - 1; i++)
{
for (j = count - 1 ; j >= 0; j--)
if (i < strlen(set[j]) - 1)
printf("%c", set[j][i]);
else
printf(" ");
printf("\n");
}
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: