您的位置:首页 > 其它

poj 3664 Election Time

2011-11-23 10:25 351 查看
Election Time

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5030Accepted: 2750
Description

The cows are having their first election after overthrowing the tyrannical Farmer John, and Bessie is one of N cows (1 ≤ N ≤ 50,000) running for President. Before the election actually happens, however, Bessie wants to determine who has the best chance of winning.

The election consists of two rounds. In the first round, the K cows (1 ≤ K ≤ N) cows with the most votes advance to the second round. In the second round, the cow with the most votes becomes President.

Given that cow i expects to get Ai votes (1 ≤ Ai ≤ 1,000,000,000) in the first round and Bi votes (1 ≤ Bi ≤ 1,000,000,000) in the second round (if he or she makes it), determine which cow is expected to win the election. Happily for you, no vote count appears twice in the Ai list; likewise, no vote count appears twice in the Bi list.

Input

* Line 1: Two space-separated integers: N and K
* Lines 2..N+1: Line i+1 contains two space-separated integers: Ai and Bi

Output

* Line 1: The index of the cow that is expected to win the election.

Sample Input

5 3
3 10
9 2
5 6
8 4
6 5

Sample Output

5


#include<iostream>
#include<algorithm>
struct vote
{
int vo1;
int vo2;
int index;
};
int comp1(vote v1, vote v2)
{
return v1.vo1 > v2.vo1;
}
int comp2(vote v1, vote v2)
{
return v1.vo2 > v2.vo2;
}
using namespace std;
int main()
{
int n,k;
int i;
vote in[50000];
cin>>n;
cin>>k;
for(i=0;i<n;i++)
{
cin>>in[i].vo1;
cin>>in[i].vo2;
in[i].index=i+1;
}
sort(in,in+n,comp1);
sort(in,in+k,comp2);
cout<<in[0].index<<endl;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: