您的位置:首页 > 其它

poj 3627 Bookshelf

2011-11-23 10:21 465 查看
Bookshelf

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 5281Accepted: 2620
Description

Farmer John recently bought a bookshelf for cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

Each of the N cows (1 ≤ N ≤ 20,000) has some height of Hi (1 ≤ Hi ≤ 10,000) and a total height summed across all N cows of S. The bookshelf has a height of B (1 ≤ B ≤ S < 2,000,000,007).

To reach the top of the bookshelf taller than the tallest cow, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf. Since more cows than necessary in the stack can be dangerous, your job is to find the set of cows that produces a stack of the smallest number of cows possible such that the stack can reach the bookshelf.

Input

* Line 1: Two space-separated integers: N and B
* Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the size of the smallest set of cows that can reach the bookshelf.

Sample Input

6 40
6
18
11
13
19
11

Sample Output

3


#include<iostream>
#include<algorithm>
using namespace std;
int cmp(int &a,int &b)
{
return a>b;
}
int main()
{
int n;
long int b;
long int sum;
int i;
int count;
int cows[20000];
cin>>n>>b;
for(i=0;i<n;i++)
cin>>cows[i];
sort(cows,cows+n,cmp);
sum=0;
count=0;
for(i=0;i<n;i++)
{
if(sum>=b)
break;
sum+=cows[i];
count++;
}
cout<<count<<endl;
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: