您的位置:首页 > 其它

poj 3624 Charm Bracelet

2011-11-23 10:21 246 查看
Charm Bracelet

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 10693Accepted: 4830
Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from the N (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weight Wi (1 ≤ Wi ≤ 400), a 'desirability' factor Di (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more than M (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..N+1: Line i+1 describes charm i with two space-separated integers: Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

4 6
1 4
2 6
3 12
2 7

Sample Output

23


#include<iostream>
using namespace std;
const int maxn = 100 * 3500;
int f[maxn];
int M,N;
int c[3403];
int w[3403];

int max(int a,int b)
{
if(a>b)
return a;
return b;
}

void ZeroOnePack(int cost,int weight)
{
for (int i = M; i>= cost; i--)
f[i] = max(f[i], f[i - cost] + weight);
}

int main()
{
int i;
cin >> N >> M;
memset(f, 0 ,sizeof(f));
for (i = 1; i<= N; i++)
cin >> c[i] >> w[i];
for (i = 1; i <= N; i++)
ZeroOnePack(c[i],w[i]);
cout << f[M] << endl;
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: