您的位置:首页 > 其它

poj 3176 Cow Bowling

2011-11-23 10:01 190 查看
Cow Bowling

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 9426Accepted: 6216
Description

The cows don't use actual bowling balls when they go bowling. They each take a number (in the range 0..99), though, and line up in a standard bowling-pin-like triangle like this:

7

3   8

8   1   0

2   7   4   4

4   5   2   6   5

Then the other cows traverse the triangle starting from its tip and moving "down" to one of the two diagonally adjacent cows until the "bottom" row is reached. The cow's score is the sum of the numbers of the cows visited along the way. The cow with the highest score wins that frame.

Given a triangle with N (1 <= N <= 350) rows, determine the highest possible sum achievable.
Input

Line 1: A single integer, N

Lines 2..N+1: Line i+1 contains i space-separated integers that represent row i of the triangle.
Output

Line 1: The largest sum achievable using the traversal rules
Sample Input

5
7
3 8
8 1 0
2 7 4 4
4 5 2 6 5

Sample Output

30

Hint

Explanation of the sample:

7

*

3   8

*

8   1   0

*

2   7   4   4

*

4   5   2   6   5

The highest score is achievable by traversing the cows as shown above.

#include <iostream>
#include <algorithm>
using namespace std;
int maxnum(int a,int b)
{
if(a>=b)
return a;
else
return b;
}
int main(int argc, char* argv[])
{
int i,j;
int N;
scanf("%d", &N);

int balls[350][350];
for (i = 0; i < N; ++i)
for (j = 0; j <=i; ++j) scanf("%d", &balls[i][j]);

int DP[350];
memset(DP, 0, sizeof(DP));

DP[0] = balls[0][0];
for (i = 1; i < N; ++i)
for (j = i; j >=0; --j)
{
if(j == i) DP[j] = DP[j - 1] + balls[i][j];
else if (j == 0)  DP[j] = DP[j] + balls[i][j];
else
DP[j] = maxnum(DP[j - 1],DP[j]) + balls[i][j];
};

cout << *max_element(&DP[0], &DP
)<<endl;
return 0;
}
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: