您的位置:首页 > 其它

poj 3077 Rounders

2011-11-23 09:46 351 查看
Rounders

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 6316Accepted: 4081
Description

For a given number, if greater than ten, round it to the nearest ten, then (if that result is greater than 100) take the result and round it to the nearest hundred, then (if that result is greater than 1000) take that number and round it to the nearest thousand, and so on ...
Input

Input to this problem will begin with a line containing a single integer n indicating the number of integers to round. The next n lines each contain a single integer x (0 <= x <= 99999999).
Output

For each integer in the input, display the rounded integer on its own line.

Note: Round up on fives.
Sample Input

9
15
14
4
5
99
12345678
44444445
1445
446

Sample Output

20
10
4
5
100
10000000
50000000
2000
500


#include<iostream>
using namespace std;
int main()
{
int n;
int i,j,k;
cin>>n;
for(i=0;i<n;i++)
{
char in[10]={'\0'};
cin>>in;

for(j=9;j>0;j--)
{
if(in[j]!='\0')
{
if(in[j]-'0'>=5)
in[j-1]++;
}
}
cout<<in[0]-'0';
k=1;
while(in[k]!='\0')
{
cout<<'0';
k++;
}
cout<<endl;
}
return 0;
}



                                            
内容来自用户分享和网络整理,不保证内容的准确性,如有侵权内容,可联系管理员处理 点击这里给我发消息
标签: